Screen Freezes and system becomes unresponsive


I’m afraid it might be you’re victim of the horrible bug 109051.
Which is, well… Very ****** if that’s the case.

Ok thanks how do I set intel_idle.max_cstate=1 ?

and I have never had this problem with ubuntu(the normal one)

EDIT: nvm i found it

Note that max_cstate=1 is not a fix, just a workaround and that it has an extremely negative impact on your battery life.
(Because basically it tells the CPU never to go into low power mode)
There is something else I had some success with: setting an option in the i915 driver. You can do it by creating a file:

sudo nano /etc/modprobe.d/i915.conf

And writing inside:

options i915 modeset=1 enable_execlists=0

This might be worth a shot before going down the cstate route. I’ve had no freeze whatsoever in 3+Weeks, but it might be I’m just that lucky.


Ok I am trying that now.


this seems to have fixed it. I should know for sure in a day or two.

Thanks for your help


EDIT it just frose up i am going to try intel_idle.max_cstate=1

Hi @ParkerMC,

try a full system update which might help solve the problem?:

@wolfman I think you meant for me to run

sudo apt-get update && sudo apt-get dist-upgrade

and that did not fix it when I added intel_idle.max_cstate=1 and updated the grub it worked fine without freezing I think it is that bug in the kernel there were several people with the same CPU as me.


1 Like

Hi @ParkerMC,

you can also try running the following command:

sudo apt-get update && sudo apt-get dist-upgrade -f

The above will force any missing dependencies, restart if anything updates!.

Is it partially solved now?. :smiley:

I ran

and got:

Hit:1 xenial InRelease
Get:2 xenial-security InRelease [92.2 kB]
Hit:3 xenial InRelease
Get:4 xenial-updates InRelease [93.3 kB]
Hit:5 stable InRelease
Hit:6 xenial InRelease
Hit:7 xenial InRelease
Hit:8 xenial InRelease
Hit:9 xenial-backports InRelease
Hit:10 xenial InRelease
Hit:11 xenial InRelease
Fetched 185 kB in 2s (90.8 kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following package was automatically installed and is no longer required:
Use ‘sudo apt autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Could iucode-tool be messing it up? I have never seen that until now


I have the N2940. It’s the same processor at a lower clock-speed. It’s running Ubuntu MATE 14.04 like a champ.

This won’t solve your problems in 16.04, but Trusty is a very good base if you want a stable computer. The 3.16 kernel in UM 14.04.2 is recent enough to handle touch-pad, screen brightness etc.

I think UM devs have done a fantastic job with 16.04. But the Xenial base still has rough edges.

1 Like

@mrtribute I think that might be what I have to do to get it working right without the short battery life. :frowning:

Yes I think UM team did a great job.

Hopefully the kernel bug will be fixed soon.

Thank you all,

1 Like

Updates seem to be broken as I cannot update using any method, all of them fail: Welcome, Terminal, Synaptic and changing my software sources download location to something else!. :thumbsdown:

Works fine for me.
I’m using

1 Like

Oui oui mon ami!, I will give the french channels a try!. :smiley: :thumbsup:

with intel_idle.max_cstate=1 it works just fine now.My battery life is still longer with UM(3-4 hours) than windows(2-3 hours).

Thank y’all for all your help,

1 Like

Hey mate. It seems some Ubuntu Kernel devs are on it (thank you lord!):

You can mark yourself as affected if you have a launchpad account using the link at the top of the post.


I will do that.

For anyone else with this problem see this workaround it is much better than the other one and should be included in the kernel soon. I have it setup to run at startup and it works without intel_idle.max_cstate=1. Thanks to everyone who helped.

1 Like

Hello @mrtribute, I have a notebook that has the same processor as yours (N2940) and I have had freezing problems with versions of Ubuntu 16.04 and higher. Has some time that I am trying to find a kernel version that is stable for the hardware of my notebook.
Do you still use Ubuntu MATE 14.04.2 with 3.16.0-33 kernel? If yes, then is it really stable?
Also, can you tell me the model of your computer/notebook?

Thank you.

I have Acer V3 112P (C73H). It’s basically this one:

I remember there was a kernel bug affecting V3 111P in BIOS legacy mode so I was afraid it would affect me:

Therefore I was more than happy to see UM 14.04 run smoothly. I haven’t used this laptop a lot (less than 100 hours).

Everything works. No crashes. Maybe one time I felt the OS misbehaving and I had to reboot. Laptop hardware can be tricky: touchpad, wifi, screen brightness, battery life etc. so I definitely consider this install a success.

I even installed in Legacy BIOS mode despite the bug mentioned above. Actually I installed in UEFI mode first and that worked great too. But UEFI was a pain to set up, because I dual-boot with the original copy of Windows 8.1.

Kernel is now 3.16.0-77. It’s affected by “dirty cow” bug, but I don’t really care because it’s mainly a local exploit.

I use this laptop only occasionally, but so far it’s been great.

I have used all Ubuntu LTSes since 8.04 and I have “never” experienced OS freezes (only application freezes) until I tried 16.04 (Compiz related but still).

Reading about OS freezes in this forum also makes me a little nervous about the future of Ubuntu/Linux. I get that chipsets become more complicated, but if your OS freezes or network connection goes down it’s a really bad thing.

That’s why I love UM 14.04. No network loss, no freezing, no shutdown bugs, solid Compiz, MATE 1.8 (can’t find any bugs), solid pulseaudio (didn’t think this was possible before), good GFX drivers.

If kernel 3.16 can handle your hardware you can’t go wrong with this release!