Screen going blurry with Compiz & Nvidia drivers

So... I have a pretty huge problem with compiz. Every part of the desktop that does not get repainted slowly starts to get all blurry and unusable. If i make the area repaint itself (clicking, doing anything with it), it comes back to normal.

For now, the only solution i found is to force redraw that entire screen (CCSM > Solutions > Force full screen redraws). While this fixes the problem, it causes a MASSIVE CPU and GPU increase (at least according to the help).

I need to use Compiz for eyecandy reasons and Nvidia drivers for gaming (and the fact that Nouveau sucks)

I am using a GTX 970, but this problem also happened on Kubuntu with a GT 630... I have 2 screens.

1 Like

Can you try Compton for a while just to see if it’s Compiz’s fault or the Driver’s?

Compton works perfectly. The problem only happens when both Compiz AND the Nvidia driver are running at the same time.

1 Like

After a little more investigation, this seems to be a weird anti-aliasing issue, where everything is kind of “too” antialiased when using GPU accelerated stuff, such as Marco w/ Compton or Compiz… This looks quite weird

I found the solution!

Here are the simple steps that need to be followed :slight_smile: First of all, open a terminal (Ctrl + Alt + T) and type :

sudo apt purge nvidia-*

After that, press enter, press Y when asked if you really want to delete packages, and wait for it to be finished. Afterwards, restart your computer, fire up another terminal, and type

sudo apt install nvidia-xyz 

Replace xyz by the version you want. Same thing, press Y when asked to, wait for the end, blah blah blah.

Once you’re done, open Nvidia X Server Settings, and disable FXAA. This should be under the Antialiasing Option. Also make sure you’re not overriding application preferences. Finally, close this window, open another terminal (or use the one already opened) and type

sudo services lightdm restart

to restart MATE. Everything should work now!

4 Likes

An alternate way: Open Additional Drivers from the Control Centre and install the NVIDIA driver, then restart (if not anyway installed). Then as you say, proceed to NVIDIA X Server Settings to disable FXAA. If the driver is already running, a restart isn’t normally required.

This happened on my card as well the first time.

Thanks for sharing your solution. :slight_smile:

2 Likes

The disable FXAA worked for me too