Screen-Tearing on mate desktop with Intel integrated graphics

Hey. I am experiencing screen tearing when scrolling websites or just watching the movies via VLC.
The issue is not present on Ubuntu 20.04 with gdm being set as the window manager.

How can I fix this?

More info:

Graphics: Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
resolution: 1600x900~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.0.4

Linux android 5.4.0-33-generic #37-Ubuntu SMP Thu May 21 12:53:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Are you missing firmware files? check dmesg | grep firmware

[ 0.115562] Spectre V2 : Enabling Restricted Speculation for firmware calls
[ 2.139748] psmouse serio2: trackpoint: IBM TrackPoint firmware: 0x0e, buttons: 3/3
[ 23.058650] iwlwifi 0000:03:00.0: loaded firmware version 17.3216344376.0 op_mode iwlmvm
[ 23.088858] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-
[ 23.246430] Bluetooth: hci0: Intel firmware patch completed and activated

Should I just use gdm with mate or do something else?

Hi @frostbane,

GDM is not a window manager, it is display manager controlling, for example, your login process. Window manager for vanilla Ubuntu is Mutter, window manager for Ubuntu MATE is Marco. If you suffer from tearing you may probably want to use Marco together with Compton compositor or switch to Compiz. Unfortunately, they are not preinstalled with Ubuntu MATE 20.04, because it was considered that tearing problems are fixed now.
By the way, do you have Marco compositor enabled in MATE Tweak / Windows section?


Have a look at this:


There's a stanza you an put into X11 configuration that might do the trick...

Hey. Yes I do use Marco-Compositor I guess it was enabled by default, and with turning the Compositor off I have rid of this monstrous tearing in the browser when scrolling, I think now I can live with it, but the overall experience as just decent at it best, the default ubuntu desktop felt a lot more responsive and smooth even when scrolling in a text editor, but I guess that mutter is not supported in mate, right?

I have seen this solution from the link before I did post my issue, I think it is outdated because now there is no '/etc/X11/xorg.conf.d/' in 20.04.

You make your own xorg.conf.d, and create a file and put those lines in it as indicated.

Okay, I had to read some 'sna vs uxa' intel manual but I got it working good at least.
Thank you for help folks, best regards.

1 Like

Creating the xorg.conf.d file has fixed it for me, no more screen tearing.
This is on an old HP Pavilion g7 laptop with itel graphics running ubuntu mate 20.04.2

The laptop duel boots Win 7 where there is no screen tearing hence I knew it could do it.

I had tried several combinations of marco with and without compositor as well as enabling hardware acceleration and other settings in chrome, chromium and firefox, all still suffered some degree of screen tearing.

Fingers crossed we will get several more years of use out of the old laptop thanks to ubuntu mate.