'SeaMonkey is already running, but is not responding...'

This happens, every once in a while, and I'm supposing the browser was merely shutdown and reopened too quickly - when it rarely occurs. No big deal, I just end the task in the System monitor.

Now, all of a sudden, it is happening 1/3-1/2 of the time - for about the past three days; any thoughts?

I was thinking, at first, that the browser might be closing abnormally, without deleting the lock file, or that Seamonkey cannot find the profile folder for some reason; but, again, it doesn't always do this. :dizzy_face:

Did you remove FireFox completely before installing Sea Monkey?. :smiley:

Open Synaptic (if not installed see command below) and check that FF is indeed completely removed!.

sudo apt-get install synaptic

Hi @wolfman, no, nothing has been installed or removed in a month or more; and I keep FF installed in MATE, as my backup, so that's not a factor.

That is what perplexes me: this is generally one of those issues that either happens exceedingly infrequently, or happens always (due to bad command line arguments or lock and parentlock issues, and such).:confused:

Synaptic is in my mix, nevertheless; I got used to it during my stint with Lubuntu LXLE (it is their sole updater) and now feel a bit naked without it. :no_mouth: :grinning:.

Seamonkey is based on FF so I would remove FF and use Chromium browser as my alternative!. :smiley:

So you think that FF (or the two Mozilla’s installed at the same time) is the issue? I have to wonder why now, all of a sudden.

Just to feel less useless, I clicked on the Help menu and selected Troubleshooting Information. When the Troubleshooting Information opened, and under the Application Basics section, I clicked on Profile Directory where a window with the profile filesfolder opened. There I located the lock file which indicated: ‘***link (broken) (inode/symlink)***.’ I deleted the temporary lock file, but I’m not sure how that would prove to be be a permanent fix…

Any thoughts on the ‘link (broken) (inode/symlink)’ part of the puzzle (or any other reasons for the confused browser behavior?

I’ll get rid of the FF, if that will fix it - I rarely need it; but I’m now wondering about the broken file…: neutral_face:

Well, let me know if you have any additional ideas, regarding the above, otherwise… all the best to you & yours :smile:.

Although, FF upgraded to a new version, right about the time this thing started… :cold_sweat:

It’s still strange, though, because FF wasn’t open, at any time, when this error occurred.

P.S. I thought I had this post in ‘General Discussion.’ Does it not belong there - and was moved; or did I put inadvertently stick it here in ‘Uncategorized?’

I don’t know anything how to check broken links sorry!. :confused:

I would remove FF as stated above and then restart and see if that helps!.

If you edit the thread, you can change the forum category!. :smiley:

1 Like

I have this same problem with FF ESR on my virtual machine and NOT on the host machine. I have tried (google) fixes, but nothing has worked.

I now have a kill button (killall firefox) on my panel :frowning:

1 Like

Ok, @v3xx, if it is you telling me this… then it is more than likely unfixable - without recreating Mozilla or something :weary:.

So, if you would, verify the steps I need to take to create my kill button for Seamonkey; I, presently, have to go through the multi step process of pulling up the System Monitor, etc.

Thanks, and Happy Holidays! :relaxed:

I hope its not unfixable, its very annoying.

I do not have seamonkey installed, but I would think this would work.

killall seamonkey

That should kill it in terminal, then create a custom apps launcher for your panel.

1 Like

Where did you get the version of Seamonkey from?, it needs Gecko to run correctly I believe?.

It is not on the Debian packages site either?:


@wolfman: Via terminal/PPA. :relaxed:

1 Like

Check this out: I made up this command (I'm sure I'm not the first), and it works... kills which ever one of these browsers that happens to be open - or both at the same time; a very good button to have (I hope, at least) :sunglasses:

UPDATE: a much nicer button for this - if you have to live with the button - to end your Mozilla browsing session!

It is located here:

1 Like

Hi @mated,

here is their homepage if you still have a problem with it, you might find something you can use?:


I also forgot to mention, if you decide to install Chromium browser, you should also install the plugin with/for it:

sudo apt-get install chromium pepperflashplugin-nonfree

1 Like

Thanks, @wolfman! :smile: I love Chromium a lot; but, for some reason, my bandwidth usage is noticeably higher with it. I am aware that browsers are not supposed to, directly, influence bandwidth usage; but it-is-what-it-is.

I am not trying to speculate on the subtle reasons why - although I do have a few fact based ideas; instead I’ll just be happy that I have found a magical way to power-surf and still stay within my limits, since moving way out from the city.

If I can get off my combo of Satellite and 4G-LTE - with cable again - then Chromium will reenter my life once again :kissing_heart:.

Also, for other SeaMonkey users, this site you sent says to press F1 for the Help Manual; I did - and it looks like a good, concise resource. It is in a different format from other available SM Help goodies, and may prove more useful.

1 Like

Have you checked in Chromium settings that things like hardware acceleration, translate languages, screen font sizes etc are ticked/unticked?. :smiley: Those things might slow it down?. :smiley:

This perplexing bandwidth challenge with Chromium is all about how that SeaMonkey registers about 70% less bandwidth (data) usage. When the whole family uses Chromium vs this version of Mozilla, we run out of our monthly allotment too early.

There are few people willing to acknowledge that my Chromium situation is even happening. Others, on the various forums, still, attribute most of it to the premise of more page refreshing with Chromium. :dizzy_face: