Sharing filess between ubuntu mate 16.04

lets start off everything is installed that needs to be installed and i have tried the tutorials. Its still not working. Trying to share files between to ubuntu mate 16.04 computers. Anyone with ideas of what I’m doing wrong here?

Many of the tutorials are out of date. Samba sharing between Ubuntu systems (and Android, and NetBSD, etc.) does work.

I do not use “caja-share”. I set up my own “/etc/samba/smb.conf” for the file server and then browse with caja to the system and share name to see the files. This makes the server file sharing settings somewhat secure as the regular user does not have permission to change “smb.conf”.

Setting up the minimum for a Samba server in /etc/samba/smb.conf is:

[global]
  workgroup = Your_Workgroup_Name
  server string = %h server (Samba, Ubuntu)
  dns proxy = no
  log file = /var/log/samba/log.%m
  max log size = 1000
  syslog = 0
  server role = standalone server
  obey pam restrictions = yes
  unix password sync = yes
  passwd program = /usr/bin/passwd %u
  passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
  pam password change = yes
  map to guest = bad user
  usershare allow guests = yes

Creating a Samba share in /etc/samba/smb.conf is as simple as:

[Your_Server_Share_Name]
  path=/Directory_to_Share
  read only = no
  guest ok = yes
  create mask = 0666
  directory mask = 0777

After you change the “/etc/samba/smb.conf” file, verify that it is correct by running:

testparm -s /etc/samba/smb.conf

It is also a good idea to put your hosts IP addresses in your “/etc/hosts” file so you can access the servers by name instead of IP address.

You will need all of the UIDs to be the same on each server for PAM security to work.

Make sure your routers are not filtering any of the UDP or TCP ports that Samba might be using.

TCP Ports
netbios-ssn	139/tcp				# NETBIOS session service
microsoft-ds	445/tcp				# Microsoft Naked CIFS
#
#
UDP Ports
netbios-ns	137/udp
netbios-dgm	138/udp
mdns		5353/udp

Ubuntu 16.04 comes with Samba 4.3.9.

Mostly up to date documentation:
https://wiki.samba.org/index.php/Main_Page

BTW: Process “gvfsd-smb” does not hang at 100% on any of my systems. Others have reported problems with “gvfsd-smb” using too much CPU time.

1 Like

Where its says [Your_Server_Host_Name] is that the computer name?

? Where its says [Your_Server_Host_Name] is that the computer name?

That should read “Your_Server_Share_Name”. Half asleep I guess :slight_smile: I’ve corrected the post.

Remember to customize “Your_Workgroup_Name” too.

No problem just thankful that you know what you are doing compared to others . I have the Samba Server Configuration to installed. Also created a new smb.conf file. I still can not see any other computers in the Network fill minus my printer and windows still(see screen shoot).

Double click on "Windows Network". You should see your workgroup then:

I have two workgroups: HOME and WORKGROUP :slight_smile:

No icons come up in the Workgroup window. Going to switch to Ubuntu mate 15.10. I’m at a loss unless you have any other ideas.

There used to be a perl script called “findsmb” that is used to check the Samba server.


                                *=DMB
                                +=LMB
IP ADDR         NETBIOS NAME     WORKGROUP/OS/VERSION 
---------------------------------------------------------------------
192.168.101.202 MY_Server       [HOME] [Windows 6.1] [Samba 4.3.9-Ubuntu]

The perl script should still be available on the Internet somewhere. I think I copied mine from one of my older U10.4 servers.

The Samba server broadcasts the share info once every few minutes. The frequency was about once every 20 minutes! Once you set up the server, give it time to announce to the rest of your LAN what it has.

Feel your pain…
Stupid but, have you actually shared the folders through samba on the two machines?

If you set up the server on your client box, you should be able to see yourself.

The command:

netstat -utna | grep ":139 "

will show whether the server is running or not.

You should see:

tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN     
tcp6       0      0 :::139                  :::*                    LISTEN     

which says that Samba is running and listening on port 139.

If for some reason Samba is not running, then lets restart it:

[email protected]:/etc/init.d$ sudo /etc/init.d/samba restart
[sudo] password for user: 
[ ok ] Restarting nmbd (via systemctl): nmbd.service.
[ ok ] Restarting smbd (via systemctl): smbd.service.
[ ok ] Restarting samba-ad-dc (via systemctl): samba-ad-dc.service.

Samba log files are located in “/var/log/samba”. log.nmbd and/or log.smbd may have clues as to what is wrong.

It straight up is. Yeah I have thinking actually that I messed something important up and now am install willy werewolf going to see what happens .