Sharing Public folders between computers over the network

Upgrading to 22.04 stopped us from being able to share the Public folder in the upgraded computers. Previously we had to install caja-share to enable Public to be made shared, but that results in 'net-usershare' returned error 255 and the Folder does not become shared. The upgraded computers are able to connect to our computers running 22.10 and access thei Public folders, but the 22.10 computers cannot see Public in the upgraded computers, only print$.
We work with linux computers only, no Windows, and don't need to be able to talk to Windows at all. Also we only use the Mate Desktop, and most of what help we can find appears to be related to working with gnome desktop as thinks told to be done don't appear to exist in Mate.
Nothing we've done in previous versions seems to work, and help we've received hasn't resolved the issue, so we plan on doing a fresh install to remove any/all changes and start from scratch, but would like to know what needs to be done to enable the Public folder to become shared correctly in Ubuntu 22.04 Mate Desktop version. Any links to such information?

Currently I only can confirm that this bug exists, it is probably Bug #1972057 “file sharing net usershare returns error 255” : Bugs : Ubuntu MATE

So doing standard procedure like

sudo apt-get update
sudo apt-get install caja-share samba

then rebooting and creating share in Caja using Sharing Options leads me to the following

  1. error message in Folder Sharing window:

    'net usershare' returned error 255

  2. error messages in ~/.xsession-errors file:

    Caja-Share-Message: 11:11:41.190: Called "net usershare add" but it failed: 'net usershare' returned error 255

I need to conduct further research on the issue. Thanks for reporting!

caja-share and samba are installed.
I opened the man page on net, and was able to get Public shared using

net usershare add Public /home/$USER/Public : Everyone:F guest_ok=y

after doing that

apinunt@Dell:~$ net usershare list


apinunt@Dell:~$ net usershare info

And now I can access the Public folder on my MSI computer from other computers.