Shut-down/Restart/Power-up=Suspend on a Lenovo g50-70 running 15.10


I’m reposting this from since I’ve had no response so far:

As the title suggests; when it comes to shut-down/restart both suspend the laptop unless I try sudo poweroff or sudo reboot which work as expected. When powering-up, it goes through the GRUB (since I’m dualbooting), and then the MATE loader appears- seconds later the laptop is suspended. A mouse-click will then prompt me to the account-password interface, and after entering the password, another suspend. This often happens a third time, but it seems random.

MATE updated today (02/02/16- see below) and since then the laptop only runs through the advanced GRUB options (Ubuntu with linux 4.2.0-27-generic, otherwise gets stuck in a “lit” black screen), and now goes into suspend at least 6 times till I reach the desktop. In addition, no wireless networks would show up (post-update)- this resolved by sudo apt-get install bcmwl-kernel-source.

(status installed)

  • linux-image-4.2.0-27-generic:amd64 4.2.0-27.32
  • linux-image-extra-4.2.0-27-generic:amd64 4.2.0-27.32
  • linux-image-generic:amd64
  • linux-headers-4.2.0-27:all 4.2.0-27.32
  • linux-headers-4.2.0-27-generic:amd64 4.2.0-27.32
  • linux-headers-generic:amd64
  • linux-generic:amd64
  • linux-signed-image-4.2.0-27-generic:amd64 4.2.0-27.32
  • linux-signed-image-generic:amd64
  • linux-signed-generic:amd64
  • linux-libc-dev:amd64 4.2.0-27.32

03/02/16 Haven’t applied any changes since last update. Third power-up attempt and what seems to be random now is actually booting (took ~30mins of -loading-suspend-“lit” black screen- loops). I pressed the power-off button while stuck in a black screen and for a while some commands appeared including something about ascii [OK] and failing to start login service (didn’t have enough time to note more than that before getting into another black screen). The web connectivity also drops from time to time, while my other devices have proper access.

Ideas? :slightly_smiling:

I had a similar problem on an old “One” (generic brand) laptop, I kept getting put into suspend mode during boot, I solved the problem by downgrading the system to Ubuntu Mate 14.04 and that works fine!. :smiley:

Sorry I don’t have another answer for you!. :confused:

1 Like

Since it has only been getting worse and being in a period with little time to spare I figured I will run Win10 for a while and give a try on a clean install with XenialXerus in the future. Anyway, I really appreciate your reply. Have a good one :slight_smile:

1 Like


I forgot to mention, I did use nomodeset as a boot option, I didn’t try other boot options like acpi=off or any other options!.

1 Like

Thanks again. I tried some of the options in the past (i.e. acpi=off, acpi=forced) but nada, no difference. I wasn’t aware of nomodeset so I figured I’ll try that, but it’s currently impossible to even reach the desktop due to the high number of spm (suspends-per-minute) in order to sudo it into ~/grub :anguished:

I’m not an expert…but just before you switch to Win10 - can you try to remove tlp packet with command:

sudo apt-get remove tlp

I was faceing some issues with random suspend before with um 15.10 and not with other ubuntu distros… So just to check if this packet has some connection with suspend options.

Let me know the result please.


Hey vlajkom, thanks a lot for your time. I’ve been really busy with my studies and in need of a functional machine so I switched to Win10 prior to your response, however I will try running Xenial as soon as it’s out- in case I get similar issues I will try what you proposed and update you ASAP.
All the best! :slight_smile: