Shutdown/startup error


#1

I've just installed U-M 18.04 on an HP Envy laptop and done an update. On shutdown it hangs with error message:

[...] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [kworker/0:2:62] which repeats every second. After a bit CPU#6 joins in referring to [plymouthd:2976]

I have to hold down the power button to stop it. On starting it again a U_M popup tell me there was a "System program problem detected" but no way of seeing what it was.


#2

Hello simon68

I have not had this problem, but I remember seeing comments about it on the web last year.

Here are a couple of links to get you started:

I would try installing any missing graphics drivers first.

If that does not fix the problem you might want to try this:

Let us know if you get it fixed or need more help. :slightly_smiling_face:


#3

Thanks Alpinejohn,

I checked out the links - some of the suggestions I'd seen before (and tried without success). Maybe one of the others would work.

After posting the problem I did more experimenting. Eventually I installed Fedora in case a non-Debian derivative might have taken a different path. It hasn't. Googling the problem for other distros shows it's common.

Turning 'quiet' off enabled me to see the system closing down processes. After 35 minutes it announced they had all terminated. Nothing happened for the next 10 minutes then I gave up.

LinuxLite works! It's not what I wanted but it is usable. And I want to use the computer not spend my life fiddling around with Grub.

There is a certain irony in all the jokes about Windows and Ctrl+Alt+Del ... at least it worked!

Thanks again for the suggestions.

Simon


#4

Hello simon68

You might want to look at MX Linux:

https://mxlinux.org/

It does not use systemd, and is based on Debian (no Ubuntu).
If you look into MX Linux spend some time, it has many useful tools etc., including easy installation of Flatpaks, easy installation of a curated list of software, etc., etc.

Also consider "toggeling" the USB-3 setting in you BIOS (if you can). :slightly_smiling_face:


#5

Ctrl+Alt+Del + Windows

It does work on Linux too. If shutdown seems stuck, press Ctrl+Alt+Del many times (at least 7 in 5 seconds - I think) to get emergency reboot console message.

djb


#6

I'll try MX on another machine. My experience is that - since I'm just an OAP playing around - loading different distros and tweaking them can easily use up all my time. For now I'll stick with LinuxLite while I'm trying to do something more positive.

Thanks for the advice.
Simon


#7

Dave,
It makes me feel quite nostalgic - I remember using Windows 3.0 sometime around 1990(?). Ctrl+Alt+Del were my favourite keys.


#8

Are you dual booting LinuxLite? If so try shutting down using init 0 in a terminal under UM to see if this changes something.