Simple scan won't detect printer

I’ve recently installed Ubuntu Mate 15.04 in dual boot setup with Ubuntu 14.04.3LTS. I can’t seem to get “simple scan” to work on Mate although it works perfectly when using Ubuntu 14.04. When I open simple scan in Mate I get the message “no scanner detected”. I never had that issue with Ubuntu.
I don’t have any problems printing a document when using Mate. Why won’t simple scan detect my printer with Mate when it does with Ubuntu ?
FYI - I have an HP OfficeJet 4630.
Any help to resolve this issue would be greatly appreciated.


I noticed that your HP Officejet 4630 does not seem to be listed as supported by SANE (LINK to SANE

Have you installed the HPLIP software (LINK to HPLIP

I'm old school, my printer prints, my scanner scans. I don't like multi-function printer/scanner/fax machines. People seem to have more problems with them than with "single-use" devices.

You could try installing xsane if you've not already installed it:

That's all I can do help. Good luck!

I tried Xsane but got the same result as with simple scan.
I also have the HPLIP installed as you suggest.

Thanks for your reply,

I’ve had similar problems in the past with my HP ENVY 4500 and Simple Scan. If HPLIP is up to date and your printer is included in that version of HPLIP, then possibly what happened is that a Level 3 update (so-called in Linux Mint), did something it wasn’t supposed to do. This has happened to me a few times in the past with Linux Mint MATE. I now only allow Levels 1 & 2 updates to take place with Linux Mint 17.2. Unfortunately in Ubuntu MATE, one has no option to choose updates according to level as you do in Linux Mint. I am also using Ubuntu MATE 15.04 on my test Lenovo T61 laptop and the HPLIP version is 3.15.2. Simple Scan works OK. Until you figure out a solution I suggest using Ubuntu MATE 14.04 only.

Have you tried HPLIP-Toolbox?:

I had a similar issue. Have a Canon Pixma MG3220 All in One, and it’s wireless. Luckily someone on one of the Ubuntu forums had the same issue and gave the links to the official Canon drivers for Linux. Though it’s on their UK website and very obscure to find. To scan, I can’t use any of the Open Source scanning apps, not SANE, and not XSANE. None of them work even with the drivers installed. I had to dig in my bin folders to find the Canon ScanGear App, which came with the drivers. And only that can utilize the scanner over WiFi. Personally, the notion of having a separate scanner and printer, both of which are wired, is just not only old fashioned, but completely obsolete. Having a wired printer and or scanner is just not feasable if all you have is a laptop. Not to mention that it is now nearly impossible to buy a scanner as a stand alone. Printers yes, but every scanner I’ve found have been bundled into an All in One Printer.

Hi there! I had the same problem with a All-in-one HP Deskjet F4280 in Ubuntu Gnome 14.04. I solved it using hplip, particularly hp-setup helped me to know the problem, missing dependencies. Using hp-doctor all this dependencies problems where solved and the scanner worked just fine.
I know that this topic is quite old but I hope it helps.

1 Like