Sluggish wireless mouse

I’ve been having fun with the Raspberry Pi3. First install Raspbian and had a sluggish mouse. I found the solution and the wireless mouse is working great. I then decided to try Ubuntu 16.04.2 LTS and it too started with a sluggish mouse. I found the fix on youtube and changed Raspbian, I thought it would work with Ubuntu but I was wrong. The fix in Raspbian was in terminal - sudo nano /boot/cmdline.txt. At the end of the text line I added - usbhid.mousepoll=0. This boot/cmdline.txt does not exist in Ubuntu, so I have no idea where to go to fix this issue. I hope someone can help. Thanks.

Just found cmdline.txt in ubuntu. In Raspbian it had me make the changes in Terminal and that was where I tried to do in Ubuntu. Just opened boot_ub on desktop and found cmdline.txt and added the command usbhid.mousepoll=0 and rebooted. Now wireless mouse was working normally. Problem solved. Perhaps someone else can benefit from this information.


Welcome to the forum John. Please mark your post as solved as this will help other find a solution in the future.

Yes I will make it as solved. I looked around and not sure how to mark it as such. How do I go about it. Thanks

Looks like you found it. Thank you.

Using a new built system and Ubuntu Mate 16.04, I was having a USB keyboard and mouse issues. Mostly sluggish mouse issues. After buying another mouse and noticing the same issue, I realized that it must be an issue with Ubuntu. So I found this forum thread. It wasn’t clear what I should do. I just guessed, and it seems to work so far.
I didn’t have the “cmdline.txt” file mentioned in my boot folder, so I created one in the boot folder and just typed in “usbhid.mousepoll=0” and saved it. Seems to be working perfectly so far. I haven’t rebooted yet.
So, I guess, if you are having the same problem… (in Ubuntu 16.04 or whatever)

  1. Just create “cmdline.txt” in your boot folder (if it isn’t already there).
  2. Add “usbhid.mousepoll=0” and save it.

That should fix it, I’m guess.

1 Like

In Ubuntu Mate 20.04, you can find "cmdline.txt" file in "/boot/firmware/cmdline.txt"

1 Like

It solved my problem, and everything seems to be just fine. Thank you!