Smbd and nmbd not installing at all

I am trying a simple sudo apt-get samba which appears to complete just fine but the smbd and nmbd daemons are not installed.

has anyone seen this behavior?

I am running ubuntu mate with 16.04.4 LTS with kernel 4.13.0-36-generic…

thanks for any pointers.
Phil Kemp

I’m on Ubuntu MATE 18.04, so assuming that the Samba packages haven’t changed too much between both versions, don’t you have smbd and nmbd in /etc/init.d?

If you check the processes list with ps -A | grep smb there’s no smbd running?

Also, have you installed only the samba package? You might need other packages that are not automatically installed, like smbclient. And if you want to share folders through Caja, you’ll need to install caja-share (though it might offer to install it automatically the first time you try to share a folder).

thats the problem. no smbd or nmbd in init.d… dont know why…


If you rty to reinstall it, no errors in the terminal?

sudo apt-get install --reinstall samba

i tried removing and re-installing still no go…

Is the package actually installed? What do you get with the following?

apt-cache policy samba