Software center

Hello everyone I just installed Ubuntu mate 16.04 and was trying to see what apps are available. Everytime I try accessing it I get this message below.

Message I received
an update is needed to show all install-able apps download now Ubuntu mate 16.04

Thanks so much

Are you not offered the choice to install [download] the update?
When I launched software center I was prompted to update!
The update is about the same as the command from a terminal
sudo apt update
Regards,
Pete

Hello and thank you, No it does not give me the option to download any update for the Software center.

Open the Welcome Center. Its in the menu under “System”. Click on “Software” and then go to the last tab (a wrench) and you will see “Outdated Package List”.

Click on Update Sources List and when it finishes, click on Upgrade Installed Packages.

And your done. You should be able to install other packages now.

2 Likes

Hello and thank you, here’s what I get when I try your suggestion,

Error message:

W:The repository ‘http://ppa.launchpad.net/cairo-dock-team/ppa/ubuntu xenial Release’ does not have a Release file., W:Data from such a repository can’t be authenticated and is therefore potentially dangerous to use., W:See apt-secure(8) manpage for repository creation and user configuration details., W:gpgv:/var/lib/apt/lists/ppa.launchpad.net_gnome-terminator_ppa_ubuntu_dists_xenial_InRelease: The repository is insufficiently signed by key 2014A4CC6F1D82F0C47ECEB8978228591BD3A65C (weak digest), W:gpgv:/var/lib/apt/lists/ppa.launchpad.net_ubuntu-desktop_ubuntu-make_ubuntu_dists_xenial_InRelease: The repository is insufficiently signed by key 399B698EEA9EF163B6F9A0F62CC98497A1231595 (weak digest), W:gpgv:/var/lib/apt/lists/ppa.launchpad.net_vikoadi_ppa_ubuntu_dists_xenial_InRelease: The repository is insufficiently signed by key D84CF327B81DFEE7CF684F379F47B51FD05009CB (weak digest), W:Failed to fetch http://ppa.launchpad.net/cairo-dock-team/ppa/ubuntu/dists/xenial/main/binary-i386/Packages 404 Not Found, E:Some index files failed to download. They have been ignored, or old ones used instead.

After clicking on Update Sources list this error message comes up. Any way to correct this?

Thanks so much

I suggest:

  1. open the welcome center
  2. click on the tool icon upper right
  3. click on update sources list
  4. close welcome center
  5. try software center once again
    When posting long strings please use either:
    preformatted </>
    block quote "

This does not work I keep getting this message

Failed to download repository information, as well as the error I posted above

Hi,

try changing your software sources download location and try updating again, see the following guide for more info!:

@Wolfman I’ll give it a try thank you…

After running the command: sudo apt-get install synaptic Complete Synaptic in my terminal this is what I get

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package Complete
E: Unable to locate package Synaptic

I think the offending PPAs also need to be disabled.I would like to see your sources, In terminal…

Code:
inxi -r

And we are all getting the “weak digest”, it can be overlooked for now. This will not stop the package manager.

Are you saying I should disable this PPA http://ppa.launchpad.net/cairo-dock-team/ppa/ubuntu xenial Release’ does not have a Release file.?

I’m using Cairo dock will this effect it in any way

Vivid is the last release.

http://ppa.launchpad.net/cairo-dock-team/ppa/ubuntu/dists/

You have the option of changing your source back to vivid using your software sources, which should be ok, but you will have to determine that.

Sorry but I don't understand what you mean by changing your source back to vivid were would I make this change?

Thanks

Open your software sources

Code:
software-properties-gtk

And go to the second tab (other). Find the ppa and click on edit. then change your source from xenial, back to vivid

Keep in mind this ppa is a year old. I would think your better off dropping it.

Well it seem like the Software center is working now not sure what I did to get it working. But I still get the error message when I run the updater I’m not really sure why. I will try this change Thank you so much…

Is that screen shot from your Mate system? just asking because it look different then mine I don’t see the edit source box

The edit button will not function until you click (hilight) a source to edit. I edited my pic above.

And I am running 16o4 Mate :slight_smile:

Oh I see ok I know Mate 16.04 is kinda new but I really like the look and feel, so I’m willing to put up with a few bugs until the release date…LOL thank you so much…

Question: About this forum is there anyway for them to get a more friendly interface for this forun?
Like the other Ubuntu has just wondering.

I would suggest starting another thread on this in the "Meta Forum".

Thanks so much for the help