Software Update Crashing "Package Operation Failed"

The Software updater is crashing when I attempt to run the updater, I get an error after the “Configuring Samba” flashes across the bottom of the box. The error is “Package Operation Failed” “The installation or removal of a software package failed”. I get the options of “Settings” or “OK”. When I run Software updater again, I am presented with the same options. I have tried narrowing down to one source of updates, and attempting to install one update at a time, but I get the same result no matter what source or update I attempt.

I’ve also attempted sudo apt-get update, which doesn’t seem to update my system.
Pastebin of screenfetch and sudo apt-get update:

Anyone else having anything similar? Any suggestions for how to start troubleshooting this one?


try changing your software sources download location and then try updating again, see the following for more details and other tips!: :smiley:

1 Like

Ok, I tried a new software sources download location as outlined in “Changing your software sources download location:” and also tried to use dpkg to fix broken packages as suggested in “Fixing Broken Packages:” Updates though Sofware Updater and sudp apt-get update still both fail the same. The messages from sudo dpkg --configure -a were too long to copy the entire message to pastebin, but what I could copy is here:

Have you installed a printer?

If not in use, smfpd can be disabled.

1 Like

What version of UM are you running?, you can also try using Welcome in 15.10 and 16.04 which also has a couple of repair functions:

Do you have Synaptic installed?, open Synaptic and look for “grub and systemd” and right click both for re-installation, don’t agree to run other updates, once done; restart your system and try updating again!.

I don’t know if you are aware but please read this in case you didn’t follow this advice!:

1 Like

I noticed that you have done the apt-get update but, not apt-get upgrade. When I run into any update problems I run both of these commands and usually it will fix whatever is having trouble.

It does sound like it is not finding the source to download the upgrade, which is why wolfman suggests changing your download location, so it can contact a different source to download from.

There also may be an obstruction in communications somewhere beyond your control(like the source download server being offline for maintenance) that will be back up when you try to update later.

My two suggestions then, are to run sudo apt-get upgrade, then update again, and to keep trying. I have had this same issue, and have found that the sources were taken offline for various reasons, and worked fine when tried again later.

I will check around and see if there is anything I can find about Samba having trouble updating.

1 Like

Ok, I haven’t found anything too recent, but there have been issues in the past few years with Samba updates. Particularly with Samba3-Samba4. Apparently, Samba4 was real touchy about reading Samba3 files, and fixes varied from changing settings to rewriting config files, but usually ended up with uninstalling both and then installing Samba4.

The other was a conflict with DynDNS, which, after trial and error, looks like the solution was to setup the DynDNS again from the beginning or to again uninstall and reinstall the version of Samba you wanted to use.

You could be having an issue with the DynDNS if Samba is running when you are trying to update, I think that might cause the “Configuring Samba” to fail, since there is already a configuration running.

I haven’t installed Samba on my machines yet, but plan to soon, so I am limited in what I can answer for you.
The steps I would take would be, make sure Samba is not running, open terminal and run sudo apt-get upgrade, and then sudo apt-get update. Reboot, just in case, and then restart Samba and check that the settings are correct.
If I think of anything else, I’ll post it here.
Thanks to wolfman, I’ve seen him on many posts helping us all out.

1 Like

Thank you all for your suggestions!

What worked was a combination of removing smfpd, and marking grub and systemd for re-installation.

This has left me without my printer though, any suggestions for better ways to install a Samsung CLP 315 without putting smfpd back on the system?

1 Like