Software Updater vs terminal commands?

Quick question guys

Is using a terminal and invoking:

sudo apt update
sudo apt upgrade

the same as using the Software Updater in the System > Administration menu?

The reason I ask is the Software Updater, for me, often fails with an error message saying could not download list, check your internet connection. Terminal always works, but I was just wondering if the GUI application did more than the above. I was was thinking of making a script to do the terminal commands, but should I add anything else.

Many thanks.


1 Like

Which version of UM are you using? And could you post the error message?

Hi @ChromaticRanger,

see also:

Hi Wizd3m

I have 16.04 32bit on a laptop. The error message I am getting is this:

I did just have a quick look in the setting page as it dawned on me that maybe the problem is a dodgy PPA in the list, and that may well be the case, although I'm sure this has worked on occasions.

Thanks @wolfman I’ll take a look.

1 Like

I had this problem recently when I’d installed Opera from the Software Boutique. I deinstalled Opera and it worked fine.

Your question was "[quote=“ChromaticRanger, post:1, topic:10246”]
Is using a terminal and invoking:

sudo apt updatesudo apt upgrade

the same as using the Software Updater in the System > Administration menu?

The answer is no, they are not the same. The terminal commands will identify components for which updates are available that the GUI Software Updater does not. I run the Software Updater daily and run the terminal command “sudo apt-get update && sudo apt-get upgrade” at least once a week.

1 Like

Thanks @alpinejohn for clarifying the difference.

I think I’ll have a go at setting up a cron job to run the sudo update commands. I am a relative newbie really so this will be my first one. :slight_smile:

The problem is on my old 32 bit laptop. My main 64 bit UM 16.10 desktop does not exhibit this problem connected via Ethernet to the same network.

I did recently install Opera actually, so I have removed it to check, but unfortunately the problem remains. What I have found though is that even though the “failed to download” message appears, if I click OK I do then get some downloads happen, so I suspect that it really is just one of the PPA in the list that is failing. I’ll try turning them all off and seeing if that fixes it.

Hallo ChromaticRanger

Run the comands in the terminal.


You should see, near the end of all the text that appears when you run the update this way, which packages are causing the problem. That might give you a starting point for further remidial action i.e. de-installing something else. I’m guessing the problem may be caused by one or more ppa’s.

Sucessfull hunting! :slight_smile: