Solve the Minecraft-installer icon error

EDIT: As @wimpy states in post #2. The packages are updated. I will keep this here if you experienced this issue.

Just to let you know. I used the flexiondotorg ppa to install Minecraft manually on another computer and got an error message stating that favicon.ico could not be downloaded as it had been permanently moved, resulting in a 301 error message from wget.

It appears that the website got an overhaul and the icon can now be found at:

Just for when there is some time to change it.

A workaround:
I thought I had a nice workaround, but I kept getting the same error message over and over again, so I had to do some hacking :wink: But it worked!

First install Minecraft using the Software Boutique and then open up a terminal (F12 for tilda wil do just fine) and do the following:

cd /var/lib/dpkg/info
sudo pluma minecraft-installer.postinst

Find the following line:


And change it to


Edit 8/2/2016:

The line should read the following now:


After that run:

sudo apt-get install -f

This will remove the error message and Minecraft will install nicely


I’ve update the packages to incorporate this change. Thanks for reporting it :slight_smile:


@wimpy: there is still a 301 thrown. The location needs to be https not http :slight_smile:

I think it might well be happening again?

Connecting to (||:80… connected.
HTTP request sent, awaiting response… 301 Moved Permanently
Location: [following]
–2016-08-01 12:36:15--
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 404 Not Found
2016-08-01 12:36:15 ERROR 404: Not Found.

dpkg: error processing package minecraft-installer (–configure):
subprocess installed post-installation script returned error exit status 8
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Mojang keeps replacing the icon :slight_smile:

1 Like

Can you tell them not too, it’s very frustrating :wink:

I’m also getting this error

Unable to access jarfile /usr/share/minecraft-installer/minecraft.jar

Is it related?

Thanks for your help, by the way! :slight_smile:

You can still use the workaround as posted in post 1. But replace the following line:




@wizd3m Thanks for the tip. I’ve finally got around to updating the packages and uploading them to the PPA. They are building now :slight_smile:

1 Like

Your welcome, @wimpy