[SOLVED] Caja and FTPS connections


Is it possible to connect to a server via FTPS via the Caja File Manager?


I don’t think the Connect to Server option in Caja where you choose FTP (with login) actually uses FTP/SSL. So probably not, at least not by just using Caja.

You can however, use the package curlftpfs to mount an ftp host as a local directory

Create the mount point i.e. folder /mnt/host first, of course…

[email protected]:~$ curlftpfs -o ssl,utf8 ftp://yourserver.net /mnt/host

Then it would show up in Caja as a mounted location under “Network”. And you could always set it to mount automatically at startup as the curlftpfs link explains above.

1 Like


Thank you for your response.

I’ve installed the curlftpfs package and I’ve tried everything to get this working. I can see from the verbose that it connects successfully over FTP-SSL but if I try and access the mount point via Caja, it just hangs - nothing happens.

Here’s the syntax I’m using:

sudo curlftpfs -v -o ssl,allow_other,cacert=/home/bstones/cert example.com /home/bstones/website

Am I doing something wrong here?


Edit: Turns out the server was returning its internal IP in its PASV reply. The -o flag has an option called skip_pasv_ip. This ignores the IP address the server returns in its PASV response.