SOLVED Can't install pipelight

Hello everyone.
First of all, I need to say I’ve just been using Ubuntu for 2 days, so I’m a total noob. The problem is I’ve been trying to install pipeline using the following code:
sudo add-apt-repository ppa:pipelight/stable
sudo apt-get update
sudo apt-get install --install-recommends pipelight-multi
sudo pipelight-plugin --update

But after the command “sudo apt-get update” I get this error message:

Leyendo lista de paquetes… Hecho
W: El repositorio « xenial Release» no tiene un fichero de Publicación.
N: Los datos de un repositorio como este no se pueden autenticar y por tanto su uso es potencialmente peligroso.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.
E: Fallo al obtener 404 Not Found
E: No se han podido descargar algunos archivos de índice, se han omitido, o se han utilizado unos antiguos en su lugar.

And when I try to type “sudo apt-get install --install-recommends pipelight-multi”, I get this:
Leyendo lista de paquetes… Hecho
Creando árbol de dependencias
Leyendo la información de estado… Hecho
E: No se ha podido localizar el paquete pipelight-multi

Any suggestions?? Thank you

That PPA does not have any releases for 16.04. The most recent version there is for 15.04.

Hello @pacomartinezsoria. Welcome to our community.

I also got pipeline installed when I was beginner and I started to use Ubuntu MATE a bit more then a year ago, because with all the searching I have done only this one “supposed” to work with ViewRight plug-in that I needed to watch tv online by my local cable tv. I was struggling with getting it to work in 14.10 at the time, but somehow never worked.

Trough I believe it was never supported by Ubuntu MATE in the first place.

I found my way around by installing Firefox in PlayOnLinux (you can install it from Welcome -> Programs -> Games) which gives you a Windows based program, where you can then install plug-ins that are supported there. I installed my plug-in there and after reboot of my system manage to get online tv working on both of my laptops. :smile:

So which plug-in you wanted to Install/use in the first place?

Thank you for your answers.
I wanted to install Silverlight, which I also need to watch TV online. When I did my search on the net, I saw people installed Wine and then Pipelight and it seemed to work in Ubuntu. But you might be right, that may only work with 14.4 version or Ubuntu Desktop and not Mate.
I’ll try to do what Ele recommended and I’ll get back to you.

To David Barnes:
So you mean, that in order to make it work I have to downgrade to version 15.04 or wait till the new release is published, right?

Hi all,

try adding the Wily PPA with the following in 16.04:

sudo nano /etc/apt/sources.list.d/pipelight.list


deb wily main

Ctrl + o , Enter + Crtl + x to save.


sudo apt-get update && sudo apt-get install --install-recommends pipelight-multi

sudo pipelight-plugin --update && sudo pipelight-plugin --enable flash

Start FireFox and wait for Wine to finish, close FF then run:

sudo pipelight-plugin --create-mozilla-plugins

Info taken from here (German). I hope it helps as I haven’t tried it myself!:

@wolfman Q: Will Wily work in 16.04 Xenial? Also why nano?

Since I’m fine with my solution I won’t be trying that again any time soon… Trough in my case there wasn’t updated version of ViewRight that program required.

Thinking about it I also had a lot of problems finding how to remove it all together much later…

I’m not really that friendly with terminal yet, even after all this time.

Hi @ele,

I am not sure if it will work, it is only a suggestion!. :smiley:

As long as you have it up and running; that’s the main thing!. :smiley:

T disable Pipelight, use the following terminal (Ctrl + Alt + t) command:

sudo pipelight-plugin --disable pluginname

Info taken from here:

Hi again, I tried Wolfman’s suggestion but it didn’t work either. But I finally managed to install it follwing an online tutorial:

But when I run Mozilla the plugin crashes and I get this error:
Something went wrong, check the terminal outputlibpipelight-silverlight5.1.soapplication/x-pipelight-error-silverlight5.1 (Error during initialization: pipelighterror-silverlight5.1)

I finally fixed it! The problem was that my online TV service (Yomvi) doesn’t work well under silverlight 5.1, so I have to use 5.0. I typed this line which I found in another tutorial and now it works fine:

sudo pipelight-plugin --disable silverlight --enable silverlight 5.0

Thank you all for your help!

1 Like