[SOLVED]Failed to start load kernel modules on PI 3


#1

Hi Everyone,

I’m using a Rasp pi 3 and I’m trying to setup Ubuntu Mate 16.04.2 on it (obvisouly I’m using the Pi 3 ARM version of the distro). Each of the installation steps (wizard) run fine but when the system finally reboot I can see the very first line being something like ‘Failed to start… load kernel modules’. Everything after that is in the green but then splashscreen appears and screen flip over to a black screen and voila pi is stuck in the dark :wink:

There is obviously nothing I can change as I cannot even start the distro so I was wondering if I’m the only one in that situation and if not what would be the best course of action to fix that?

Thanks in advance,


#2

‘Failed to start… load kernel modules’ is normal, at least I get that too and my pi boots fine. It might be worth while to checkout the syslog on your pi’s sdcard @ /var/log/syslog :wink:


#3

Hi Meticulus, thanks for the feedback. I'd love to have a look to the logs but there is nothing there, actually here's a list of all the files on the SD Card:


Hope this is helpful?


#4

There should be 2 partitions:

  1. PI_BOOT.
  2. PI_ROOT.

The partition you listed is PI_BOOT. If the other is not there then… something went wrong with ‘flashing’ the sdcard.:wink:


#5

ok it's starting to make sense (for me) :wink:

Actually the other partition is there but I can't seem to be able to access it from my mac. Here's another screenshot:

I'm using Etcher to flash the card, any idea what else I could use (if that's the problem)?


#6

I think the root partition is ext3 - but I’m not familiar with macs.
It could be read by almost any linux system.
I feel you may, if the system is running, but merely ‘invisible’, be able to get to a command prompt to further investigate.
I cannot think how to do it (CTRL-ALT-F1?)
Derek


#7

I am not familiar with mac’s either. There must be some way to mount ext4 partitions on a mac so that you can see the contents of that partition. So you can check out the log and see why it doesn’t boot. Perhaps something like this?


#8

Thanks for the links… unfortunately it doesn’t work. I think I’ll try to setup Windows using bootcamp as I’m starting to get bald lol


#9

Hi again, actually I’ve tried another tool for flashing the sd on mac which is ApplePi-Baker and this is now working :slight_smile:

Just in case it’s worth noting that I also performed the installation without setting up the internet connexion so all was done offline but it’s now working thanks a lot for your support!


#10

I have a raspberry pi 3b from 2015 and it still gives me the error code
“Failed to load kernel”
What should i do?


#11

Also im on windows and im using win32