(Solved) Graphical Bugs in Ubuntu MATE + Compiz 14.04.2

I’ve uploaded some footage of a graphical related bug I’ve been running into now and then. Seems to happen on a daily basis, at some point. It’s probably just Compiz, but I’ll show it anyway for reference. That aside, distro runs beautifully for me.

Details found in description


try this (generally for Nvidia graphics cards):

Open CompizConfig Settings Manager > Effects > Animations > Focus Animation > Highlight where it says "Focus Effect" - "Dodge" > Edit > Focus Effect > Select "None" > Close

If you don't have the settings manager installed, install it via a terminal (Ctrl + Alt + t) with the following command:

sudo apt-get install compizconfig-settings-manager

You'll find it under "System > Preferences > Look and Feel" once installed. :smiley:

Hope it helps. :smiley:

Thanks, for the suggestion. I already have the Compiz Settings Manager setup. I think my OCD would kill me otherwise. lol.
Looking under the animations column, I don’t see the string you mention however. Currently, I enabled “Fix screen updates in XGL with xglrx” under Workarounds, suggested by Martin Wimpress on the G+ page.

1 Like

No problem, at least you have it working!. :smiley:

Maybe… Not certain yet. These graphical issues do not persist right away. Everything works normal a while, then the bug begins at a random time. It’s been about half a day, no regression yet.
I’ll keep everyone updated.

Do you have an Nvidia graphics card?. :smiley:

No actually. It’s a Radeon R7 240. Using the non free drivers from driver select tool.

That might be your problem as it doesn’t have a good write-up here:


I would remove the AMD/ATI drivers you installed and see if it runs better on the onboard drivers!. :smiley:

The stock open source drivers don’t agree very well with this card. I could not even max out my native screen size @ 1920 x 1080. It’s a Crossfire, so I can remove card and run from iGPU. But that would have serious impact on video performance.
About that review. No shock there. Low end AMD cards are downright awful.

Well okay then; try updating following the settings in the update guide, be sure you use “Main” as your main software source download location, it might help with the cards performance; you never know!:

I’ll try that as a last resort. I believe toggling “Fix screen updates in XGL with xglrx” has solved the problem. But not totally sure yet. If I can make it an entire day or so, should be fine.
We’ll see how that goes.

Alright, then good luck and I hope it works for you.

I have an ATI Mob Radeon HD 4250 card on my laptop and I can only use the onboard drivers!.

Alright. It happened again just now. I was working on a project in Sketchup and noticed some flickering and slowdowns. Closed it out, and opened up a video in VLC. Went black as soon as I entered Full Screen. So clearly something is still up.


then I would try doing what I posted at the beginning and look carefully at the pic I posted as the string is correct!.

Another shot with the line you need to edit highlighted, then just click on "Edit" and select "None" then close:

K. It’s been applied. Now to sit on it and see what happens.

Good luck, I hope it works out for you!. :smiley:

Yeah, hopefully these tweaks will hold up for me. Thanks for all the suggestions.
btw, Fix screen updates in XGL with xglrx seems to have also had a little bit of affect itself. When the video problems begun occurring again, the flickering wasn’t as ambitious. Still enough for me to log off, but at least I know I’m looking in the right direction. So I get a general idea.

If anything goes wrong, you can globally disable all animations: CompizConfig Settings Manager > Effects > Animations > Enable Animations (Take the tick out of the box on the left!):

I see. And about the string you told me to adjust earlier. You’ve seen graphical related issues solved over that? The bug is pretty random. Stuff works great for hours, then randomly VLC turns black, and a bunch of graphically accelerated programs all break. Even screensavers will then fail to initiate. I have to log out and come back to solve it. Today has been fine, but it may happen at any given time. Hopefully I have it under control now. If not, I’ll keep tinkering with settings.
Update: The issue is nearly fixed now. Only Sketchup & Earth are impacted, that I can see. I repaired VLC by switching video layout to X11. So I’ll now look into specific workarounds for Google Earth and Sketch.
Thanks all for the support.

1 Like

Believe I found my culprit: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/224893
It’s OpenGL related. Kinda out of ideas what to do with it. Of course, it has to be my cheapo AMD card. lol