[SOLVED] Installing Ubuntu MATE 14.04.2 on Lenovo G40-45 (A8-6410)

Hi all,

I just purchased a Lenovo G40 laptop and not wanting to use the Windows 8.1 that came pre-installed, I switched the BIOS to legacy mode and I installed the first half of the hard disk with Windows 7 Professional (x64). That was the easy part.

I then decided to install Ubuntu MATE 14.04.2 (LTS). The funny thing is I selected not to install Ubuntu on the entire hdd and the installer didn’t have the option to install Ubuntu into the largest free space.

I manually created an ext4 partition, a swap partition and a 1MB BIOS partition and pretty much left everything else to default.

My problem now is whenever I restart my computer, instead of getting the grub screen, I get a grayish white screen and after a few seconds, the computer starts into Ubuntu. I do not get to see the usual grub screen and if I want to boot into Windows, have to boot directly into Windows partition when I hit the F12 key for boot options.

Can anybody help or have similar experience as myself? Please feel free to ask me any question or additional information you may need to help me with this problem.

Thanks in advance.

Log in with a live cd/usb

Go to this site:


Install boot repair whilst inside your live environment and run it.

Use “recommended repair”

It should automatically pick up both of your OS’s and put the correct entries into grub.

Then shut down, remove your live usb/CD and restart in the normal fashion. You should find both windows and ubuntu mate are now listed in the grub menu

1 Like

Hi stevecook172001,

will give this a try when I get home tonight. Didn’t work when I installed that to the hard disk, will try it from a USB or DVD live disk.


Hi @ajack just to append to what @stevecook172001 suggested, once you booted into your Lenevo from Live CD / USB in order for Boot-Repair to work, 1st you need to enable community-maintained free and open-source software (universe) from - System> Preferences>Hardware>Additional Drivers

The boot-repair process works flawlessly but if it doesn't work for you then report back , there is another way to get your dual-boot problem fixed .
Slightly related topic
Cheers :+1:

1 Like

I’m not sure if this information is useful…


Problem solved, there was a GPT partition instead of an MBR on the hard disk. Deleted all partitions and got gparted to write a new msdos partition effectively deleting the GPT and replacing it with an MBR. Thanks to all for your assistance. UEFI and GPT are new to me. My bad (and I’ve been using Linux since 2005)… :confused:

1 Like

Glad to hear you got it working ajack. I should say, I had a problem with UFEI on my new Asus rig. Went into BIOS and changed something and got it to work. Can’t remember for the life of me what the heck it was I changed though!

Good stuff @ajack … GPT works well on HDD’s above 1 Tera or 2 Tera, otherwise MBR is the standard partition tables format.


I have a similar issue about my ubuntu mate installation. Thing is, I’m totally new at Linux and I just want to give it a shot using ubuntu mate, not to mention that I’m new handling terms about hard drives, boots types (UEFI / Legacy mode) and this installation is making me learn in bad ways. :sob:

My pc is a Lenovo thinkpad edge e430. My problem is, in the process of installing ubuntu I was looking access to boot from a DVD by default my lenovo pc doesn’t. It was a problem get into de BIOS to change that but finally could using the Windows secure restart method. Once I got entered into BIOS I changed my boot mode, it was configured to boot in both UEFI and Legacy mode and I changed it for just legacy mode (my big mistake here). After that I could boot into the dvd and install ubuntu but a I was not able to get back to windows (obvious reasons my windows boot on UEFI mode) because I can’t have access into BIOS. I tried everything I found on web, all the methods and keys suggested by Lenovo but nothing work, it just boot to ubuntu and nothing else.

Can anyone give me a hand on this? this happened to someone before? How can restore the default config or enter in BIOS? Exist some method like windows on ubuntu to get into BIOS?

It will be very appreciate some help around here. I don’t want to loose my windows and data.

Kind regards to everyone.