[SOLVED] Multiple display 16.04 loginscreen placement

Upgraded from 15.10 and now i have problems with the placement of the login screen on my dual display setup.
Can not find any working solution to choose on which screen the login menu shows up. When logged in I can control on which screen the menus and such shows up.
Main display is connected to DVI-0 and extra display which is turned 90 degrees for reading, is on my VGA-0
Having login screen turned 90 degrees is working but not optimal :slight_smile:
Only found info for older releases of Ubuntu Mate but nothing of that seems to be applicable here.

Anyone solved this issue and willing to share some hints
Thanks in advance

Hi @Magnus_Holmstrom,

does this help?:

Just open Displays in Control Center and click on Set as Primary of the monitor you want to use as Primary. If necessary click on Aplpy system-wide, but I did not have to do that.

(screenshot below is from the interwebs, I am not home right now).

On my dual setup, the login is on my main screen (connected using HDMI).

Thanks for the responses.
Have been playing around with both the xrandr command from the video and the display utility from controlpanel but unfortunately they both works fine for changing display after you are logged in but not for the login screen placement itself.
Tried some changes in the lightDM config files but did not get anything usefull from that so far.

Is this what you tried? Greeter setting is in your menu.

Hmm looked at that to but do not realy inderstand how this affect my display choise for login screen. Maybe I am missing somthing… I did find some old info for previous releases of Ubuntu Mate regardingsetting info in lightDM config files to control login screen. But layout of config files have changed since then so my experiments have not succeded with that.

So my rela question is where do we control the placement of the login screen? Is it LightDM that does this or is there some other functionality that is controling this.

[SOLVED] After enabling debugging in lightDM I found out which config files where read and in what order.
In /etc/lightDM the only file that seems to be read is the ubuntu-mate version of the conf files. In this you can find a setting called active-monitor. This is set to 0. I changed it to 1 and this moves the login screen to my other display.This setting is not from what i can se, changeble in the lightDM gtk greetings GUI. Would make life easier for users if it was i think.


Hi, this is the exactly file in 16.04:

[email protected]:~$ grep "active" /etc/lightdm/lightdm-gtk-greeter.conf.d/99_ubuntu-mate.conf
[email protected]:~$ 

Thanks for the tip!

Worked for me :slight_smile: the last option on /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf