SOLVED: Printing in WINE application not working ( snap Notepad++ and UM 22.04.1)


I'm facing troubles with printing from wine application. Distribution is UM 22.04.1 with all recommended updates. I have installed Notepad++ via snap with this configuration:

Notepad++ v8.4.9 (64-bit)
Build time : Jan 27 2023 - 03:11:16
Path : Z:\home\user\snap\notepad-plus-plus\386\notepad-plus-plus\notepad-plus-plus.exe
Command Line :
Admin mode : ON
Local Conf mode : OFF
Cloud Config : OFF
OS Name : Microsoft Windows 7 (64-bit)
OS Build : 7601.0
Current ANSI codepage : 1252
WINE : 7.22
Plugins :
mimeTools (2.9)
NppConverter (4.5)
NppExport (0.4)

In Notepad++ basic setup do not support system printers so I enabled them with following command :
snap connect notepad-plus-plus:cups-control

Screenshot at 2023-02-09 22-11-53

Libcups2 and libcups2:i386 who are vital for CUPS printing are also installed.

In my case I would like to print form Notepad ++ on couple of printers. All of them are network printers. First is Canon MB-2100 series which is connected via print server (Networking Print Server) and second one is HP 1102w who is connected via RaspberryPI -> acting as print server and have HP-lip driver support installed.

Printing direct from Ubuntu MATE desktop works flawlessly, but printing within wine application is fruitless. Printer Queue of the printer is empty after printing was initiated. Notepad ++ do not even respond with some error(s).

What did I miss to get printing working? Somehow it seams that wine application do not push print file to CUPS. Should be some broken procedure or inadequate permissions or something else?
I'm facing this issue on two PCs.

Thank you for your replays and suggestions.


Hello firmwarebug

I cannot help with your printing problem.
I do use Notepad++ on my employer's (Windoze) computer. It is very useful.

On Linux I personally have not and would never install wine - but everyone is free to do as they choose. :penguin:

On Linux the first program that I install/check it is already installed is the packet manager Synaptic.
The second is the KDE text editor Kate.

Have you considered using Kate on Linux in place of Notepad++? :slightly_smiling_face:

Hi alpinejohn,

Thank you for your replay.
I have already looked for Linux alternatives (Kate, Geany.. ) and I can confirm that my working scenario is the same. I use Notepad++ on my work and therefore I would like to use it also on my home computer.

It works actually pretty well, only printing is somehow stuck.

Have you looked at the Linux Notepad++ clone notepadqq ?

sudo apt install notepadqq
1 Like

I have notepad++ installed (I use for HTML), and I have no issues printing. Perhaps reinstall it?


I have removed snap package ( after tried to reinstall it..), setup Wine 8.0 stable, downloaded and installed npp.8.4.9.Installer.x64.exe.

Printing works fine.

Thank you all for your help.