[SOLVED] Problems trying to install QGIS 2.8 Wien LTS

Hello, Greetings everyone!
I am loving the lightness and speed of Ubuntu Mate. Installing it in my new Samsung 850 EVO helps a lot with the speed too.

I have Ubuntu MATE 15.04 Vivid but I am having a few problems installing my favourite GIS mapping software.

Here is what I'm entering:

herman@herman-P5QL-PRO:~$ sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
[sudo] password for herman:
Unstable releases of Ubuntu GIS packages. These releases are more bleeding edge and while generally they should work well, they don't receive the same amount of quality assurance as our stable releases do.
More info: ubuntugis-unstable : “UbuntuGIS” team
Press [ENTER] to continue or ctrl-c to cancel adding it

.. and here is what I'm getting back,
> gpg: keyring /tmp/tmp7zvi98nn/secring.gpg' created > gpg: keyring /tmp/tmp7zvi98nn/pubring.gpg' created
> gpg: requesting key 314DF160 from hkp server keyserver.ubuntu.com
> gpg: /tmp/tmp7zvi98nn/trustdb.gpg: trustdb created
> gpg: key 314DF160: public key "Launchpad ubuntugis-stable" imported
> gpg: Total number processed: 1
> gpg: imported: 1 (RSA: 1)
> OK

It keeps giving me QGIS 'stable' when I'm asking for 'unstable'.

That means it keeps installing QGIS 2.4 Chugiak.
I need QGIS 2.8, 'Wien', which although classed as 'unstable', is actually the LTS version and works really well. I have been using it for a while now in regular Ubuntu and had no problems with it. I always use the 'unstable' versions of QGIS. It always has been a struggle to get installed, even in the normal Ubuntu. It would be great if I can use the latest version of QGIS in Ubuntu Mate. I'm not asking for 'testing', just 'unstable'. But even if I was asking for 'testing', I would expect to be able to install it.

Is installing an 'unstable' version not allowed in MATE?
Am I doing something wrong?
Will I need to try compiling from source?

Thanks in advance if you can help and thanks to the devs for making Ubuntu MATE, I think it's great so far.

Regards from Herman

Looking at what is actually in the repository, it looks as though the owners haven’t built qgis for vivid (15.04) - the most recent version was built for utopic (14.10). In fact, they have built very little for 15.04 - most packages stop at 14.10.

In this situation command-line installs tend to fall back unpredictably to older versions, or fail completely.

The fix is either to build it yourself or (better) ask the repository maintainers to keep the repository contents up to date.

A more drastic fix would be to use Ubuntu MATE 14.04 LTS rather than 15.04. This would pick up the trusty version of qgis from the repository (2.8.1).

Oh okay, thanks for your help. After doing some more reading it looks like you’re right.
I’m not sure what to do now. I guess I’ll have to try Ubuntu MATE 14.04 LTS, although it seems like a painful thought to have to do without some of the great work the MATE devs have been doing. It doesn’t look like I can have the best of both at the moment. Maybe after the next new LTS version of Ubuntu and Ubuntu MATE come out if QGIS is supporting LTS versions then I will be able to get the newest of everything. Another idea might be to dual boot two versions of MATE maybe.

Thanks again for your helpful advice,
Regards from Herman

Problem solved - I re-installed with Ubuntu MATE 14.04 LTS and then I installed QGIS. Quantum GIS Wein 2.8 appeared effortlessly.
I am guessing that I will only need to wait a few months until 15.10 will be released. I think that will be the next Ubuntu LTS, so probably QGIS will support it. Then I will upgrade my Ubuntu MATE and have the latest of both my favourite operating system and GIS software. :slight_smile: