(Solved) Unable To Change Cursor Theme

Hi everyone,
I’m on a fresh install of Ubuntu MATE 15.04. I see there are a number of pre-installed cursor sets already, however selecting one does nothing. To test, I tried installing the Chameleon theme. Attempting to apply it also failed.
So from there, I tried logging out to see if doing so would apply the changes on next session. My desktop workspaces broke and only showed 2 virtual desks. Had to use the MATE Twak and reset panels.
Has anyone faced this kind of problem before? 14.04 behaved in the same way, after some time.
Thanks

Hi Ryan,

change your software sources download location to "Main" (if not already) and run a new update, if it is set to Main, change it to something else!:

Was set to US server. I changed it to the main location. It has behaved pretty funny before, actually. Downloads transfers in Software Centre taking unusually slow, sluggish update connections. So we’ll see how this goes.
I’ll do an update from the Terminal, then check the graphical updater.
You think I could have damaged packages?

That is possible, if you want to use the terminal, run the following command and it will (should) fix dependency issues:

sudo apt-get update && sudo apt-get dist-upgrade -f

Run the dist-upgrade command? That won't stick me on some RC or anything will it? I'm on a clean setup of 15.04.
Also, Windows is installed on a separate hard disk on here. Could that in any way harm it's partition tables or anything? I always disconnected it when altering the Linux installation here.

Hi Ryan,

no it won't, "NB: "dist-upgrade" will not update your OS to the next highest version!." (Extract from the update guide wot I rote!.)

As long as you have the bootloader on the first HDD ( /dev/sda/ ) you shouldn't have a problem. Windows should be installed first though, if you put Windows on the PC after you installed Linux, it can lead to problems!. :smiley:

Windows was installed as the 1st OS. It’s also, physically on a different drive. It sits on a 2 TB WD Green, and Linux runs from my 2 TB Seagate Barracuda. Yes, it contains it’s own bootloader. Just the stock MBR. No GRUB or anything there.

Is this the primary HDD? (Master). :smiley:

I guess it is. It is installed as the 1st device in the slot. GParted also reads the WIn disk as dev/sda1, and Linux dev/sdb1.

If your Linux bootloader is on on /dev/sdb1, download a copy of “Boot Repair” and purge GRUB and make sure it installs to /dev/sda/:

http://sourceforge.net/p/boot-repair-cd/home/Home/

If you have 2 HDD’s, you should install GRUB to the MBR on the first HDD!.

Is that really needed? I like leaving the Windows drive with no traces from Linux. Just straight to MBR. I can always have GRUB show the screen on the second disk. That can send me back and fourth too, without altering anything.

Hi Ryan,

you can leave as is, that is up to you, I would recommend re-doing the bootloader, take a look here although it doesn’t really say much for my argument!:

https://help.ubuntu.com/community/Grub2/Installing

and:

http://www.gnu.org/software/grub/manual/grub.html

The important thing is that you do the system updates!. :smiley:

Gotta go, “Match Of The Day” is on!. :smiley: Speak later!. :smiley:

Alright. Appreciate all the info.
Watching a movie myself. lol :wink:

Hi Ryan,

further to your question about "dist-upgrade", this is how you do a full distro upgrade should you want to:

Did the terminal command solve your problem?. :smiley:

It found nothing to upgrade to. So no, it did not I’m afraid.

Alrighty then, try this one as it is possible that you have a broken install!???:

sudo apt-get update && sudo apt-get install -f

Restart if anything at all updates!. :smiley: