Some app windows don't fit my HP Mini 210-4000 screen

Hi there.
I love this distro. It is so stable. Why do I say that? Well, I installed Ubuntu Mate 16.04 a month earlier than Windows (dual boot) and I as far as I remembered Windows crashed multiple times but this distro only once. So I use Linux everytime and the other OS very seldom (only to watch mkv videos until I someone told me how great SMPlayer/MPV is).

Any way there is something I noticed about this distro. Some apps windows does not fit in my netbook’s screen. I mean like GIMP, I can’t see some toolbars because there way below the screen and I can’t scroll down because I can’t, no scroll down bar. To go down I have to press ALT and use the mouse scroll wheel. But I’m beginning to feel this a bit tedious.

There were other apps whose windows doesn’t fit but can’t remember the names because I uninstalled them.

Any comments I would really appreciate it.

[quote=“rex_everett_Tibus, post:1, topic:13104”]but this distro only once[/quote]How’d you manage that one? I actually never managed to get it to actually crash hard. Best I can manage is locking up the UI (by means of a stalled Windows game run in Wine) but actually hard crashing Ubuntu? Not once, been using it for years.

Anyhow, on-topic – I would start by having a look at the display settings (Control Center > Displays) to make sure you’re actually running the correct resolution.

1 Like

Certainly a working resolution is essential, but many linux apps use fixed-size dialogs and suchlike, which can end up being partially offsreen if your device has a native resolution of 1020x600 or something.

Alt+F7 lets you grab the window and move it around without being able to see its title-bar. fwiw.

(I solved the problem by switching distros and buying higher-resolution laptops, mileage varies.)

1 Like

[quote=“crankypuss, post:3, topic:13104”]Certainly a working resolution is essential, but many linux apps use fixed-size dialogs and suchlike, which can end up being partially offsreen if your device has a native resolution of 1020x600 or something.[/quote]Well, I was more thinking along the lines of it simply having been set incorrectly and the windows simply being spawned in a region that is outside the resolution.

Working example of this is when I run a demoscene demo in wine and then have it crash without it resetting the resolution. I’ll now have windows (of applications I had running) that exist beyond my visible view. Because now the DE is set to the improper resolution. Anyhow, it was just a thought.

1 Like

That can happen too, and a usable desktop resolution is important, but Alt+F7 can get you at least to where you can work yourself out of a box of some kind. Party on! :slight_smile:

1 Like

My resolution is set at the highest 1024x600. I think @crankypuss is right that there are linux apps which are fixed-sized and are not configured for smaller screens. I did some surfing and found out there are apps with fixed-sized resolution. that’s where I found the ALT key to move the app.

About the crash, I think it .was my fault I was clicking and tweaking (I can’t remember exactly what) until the OS froze–no matter how I move the mouse or using the up or down keys it just froze. It could be the hardware not the OS. Anyways, I just rebooted and had no problem since then.

Hm, just a thought:

Does MATE support vertical virtual workspaces?

In this way, if a window extends the screen, it would become visible on the second virtual one.

1 Like

[quote=“rex_everett_Tibus, post:6, topic:13104”]are not configured for smaller screens.[/quote]Then just how low is your resolution? Anyhow, to offer you an alternative – try Pinta instead of GIMP. Resizable, single window. It is not as feature rich as GIMP but it is a useable alternative.

How low is my resolution?
Well, looking up in my hardware display the highest resolution is 1024x600 and the lowest is 320x240 (if that is what you meant).

for now I’ll stick with GIMP, cuz this app is just so cool almost rival Corel Draw in features. I haven’t tried connecting the laptop to a secondary monitor, I think it will probably solve the issue.

for now I'll stick with GIMP, cuz this app is just so cool almost rival Corel Draw
[/quote]Well, can't say I didn't try.

TL;DR -- There is no solution but to purchase better hardware, in your case.


I agree buying a new computer is probably the answer, but I just can’t set this netbook aside because well, yes IT IS old but it still works–thanks to Ubuntu Mate 16.04. And I could do just about any computer jobs on this little thing. One thing I’ll do though is to buy an external monitor-- a big one!

I temporarily solved my GIMP screen problem by going to Window menu and un-clicking the Single Window option to un-dock the dockers and I can move them to see all the tools

To you all, thank you for your suggestions and thoughts, very much appreciated you took time for me :slight_smile:

1 Like

[quote=“rex_everett_Tibus, post:11, topic:13104”]un-clicking the Single Window option to un-dock the dockers[/quote]I never liked GIMP’s multi-window approach but in your case I can see it being very useful indeed. And, that external monitor would most decidedly help.

Just make sure to research the subject beforehand though, to make sure the netbook will support it properly. Good luck and see ya around.

1 Like

@rex_everett_Tibus Please see -

which may be of some help.

1 Like

your suggested XRANDR did help…in some way.

i followed this youtube tutorial and when i followed the commands in terminal xrander worked. but when i copied his file and saved it in my computer and then rebooted.

after i got past GRUB. nothing it didn’t load ubuntu mate. i mean nothing but blank screen. i rebooted again and waited for 4 hours but nothing on the screen there’s no indication that the computer is working. led lights are on but no activity…i kinda puzzled like i asked myself did ubuntu crashed?

I tried erasing the file from the xorg.conf.d folder but found out i could not because i was on LIVE USB ubuntu and it seems i don’t have permission because i wasn’t the “owner”.

Running on live-usb you ought to be able to make yourself the owner by using sudo. If you don't mind ignoring a bunch of messages you can ctl-alt-t to get to a terminal, then "sudo caja" to run caja as superuser and change the permissions. Or you can bring up a terminal and start with "man chown" and "man chmod".

1 Like

hello crankypuss,

can you do me a favor? can you list down the commands in terminal in order to delete this file : /usr/share/X11/xorg.conf.d/10-monitor.conf

this is the file i saved and i believe if i can erase this file my ubuntuOS will load up finally…i believe this is the one that probably crash the OS or why the OS would not open.

i am going to try using the LIVEUSB to delete this file…man its been days since i used ubuntu mate. i miss it already. i am sadly using windows7 for now…ssiggghh…

its ok man. i deleted the file thanks for suggesting to use “sudo caja”. it worked. now i can open ubuntu again…

Glad to hear your system is working again, i was afraid for a minute i was going to have to choke up some actual commands, mostly i dig them up and put them in some script then forget everything.

1 Like