Some applications have a huge interface

I've recently installed Ubuntu-Mate on a recent, bare-metal laptop. Some of my applications are appearing with a huge interface - fonts and windows. I suspect these are QT . For example, VirtualBox and Kate, are unusable. It appears that the DPI is all wrong. It is not a monitor issue, all of which are standard DPI (not HiDPI).

I have tried to correct it via Kvantum but it doesn't seem to have setting that affects the DPI. Any ideas would be greatly appreciated to correct this problem.

1 Like

Welcome @MaxKa to the community!

I ran the ubuntu updater today and now everything seems to be corrected. Both Kate and Virtualbox seem to be at the same dpi as the rest of the system.

The following are the log updates:

Start-Date: 2022-11-24  12:33:53
Commandline: aptdaemon role='role-commit-packages' sender=':1.106'
Upgrade: openssh-client:amd64 (1:9.0p1-1ubuntu7, 1:9.0p1-1ubuntu7.1), xserver-xorg-core:amd64 (2:21.1.4-2ubuntu1, 2:21.1.4-2ubuntu1.1), imagemagick:amd64 (8:, 8:, libexpat1:amd64 (2.4.8-2, 2.4.8-2ubuntu0.22.10.1), libexpat1:i386 (2.4.8-2, 2.4.8-2ubuntu0.22.10.1), firmware-sof-signed:amd64 (2.1.1-1ubuntu1, 2.1.1-1ubuntu1.1), libmagickcore-6.q16-6-extra:amd64 (8:, 8:, xserver-xorg-legacy:amd64 (2:21.1.4-2ubuntu1, 2:21.1.4-2ubuntu1.1), xserver-common:amd64 (2:21.1.4-2ubuntu1, 2:21.1.4-2ubuntu1.1), libmagickwand-6.q16-6:amd64 (8:, 8:, imagemagick-6.q16:amd64 (8:, 8:, libmagickcore-6.q16-6:amd64 (8:, 8:, imagemagick-6-common:amd64 (8:, 8:
End-Date: 2022-11-24  12:33:55

I'm back to square one: GTK apps such as Kate and Virtual Box have huge window elements. I am still seeking a solution.


1 Like

Not to be nitpicky, but (emphasis added)...

...I think you meant Qt here.

Nitpicking aside, here are some things to try:

  • First, open a terminal window and type (or copy and paste):

    env | grep ^QT

    I would be very interested to see what output that command produces. Most likely, one of the lines of output will start with QT_SCALE_FACTOR= and will be followed by a number from 1 to 3. On my normal-DPI monitor right here, I get three lines of output from the above command:


    The last line of output indicates that Qt will draw windows at normal size since my monitor is a plain-old normal-DPI monitor.

  • Try running some Qt program from the terminal (close any existing open instances of the application first), but precede the command name with QT_SCALE_FACTOR=1 -- so for example, try launching Kate like this:

    QT_SCALE_FACTOR=1 kate

    Does that cause Kate to open at the correct size?

  • Do you have any idea if these Qt applications exhibiting this odd behavior are Snap, Flatpak, or other weird package formats (i.e. the applications were not installed using apt)? I myself wouldn't know how to check that (my apologies), but I've heard stories about Snaps and Flatpaks that didn't integrate well with the user's desktop -- usually because the applications are (by design) isolated from the user's desktop for "security" reasons. Something tells me Kate is not a Snap, but for all I know, Ubuntu may have gone totally Snap-crazy and now VirtualBox might be a Snap, just like Firefox is now. It might be interesting to list the contents of your /snap directory and see if you see a folder for VirtualBox.

  • If you could take a screenshot of a Kate window that exhibits this behavior, that could be very revealing to us. We might figure out it's caused by a buggy style plugin / theme (or something) that is confusing Qt. This would not be the first time that a Qt theme confused Qt.

I'm no supreme authority on this matter, but I've been writing a Qt style plugin lately and thus I'm fairly fresh on my Qt knowledge. I hope to see the results of the experiments I listed above. Thanks in advance.


Oops, of course I meant QT apps are problematic.

env | grep ^QT output:


QT_SCALE_FACTOR=1 kate results in the same huge interface.

Both applications are listed as Ubuntu deb installs in the Software app.

Here is Kate:



Hmm... I notice that extra variable QT_FONT_DPI=144. Try launching Kate with QT_FONT_DPI=96 (I think most single-density monitors are about 96 dpi -- mine is at least):

QT_FONT_DPI=96 kate

I suspect that will display Kate in normal size. Still, I have no idea why the QT_FONT_DPI environment variable is set. I assume you haven't set a custom font DPI level in, say, the Appearance Preferences -> Fonts tab -> Details button -> Dots per Inch (DPI), have you?

1 Like

Interesting gordon, your suggestion worked. Both apps are normal size when given QT_FONT_DPI=96. But under the Font Details the resolution is set at 96 dpi and auto detection. I tried export QT_FONT_DPI=96 but that isn't changing the appearance. I wonder if the is a way to make this permanent?