Some errors in groovy showing up in apt updates && autoremove

Do you want to continue? [Y/n] y
(Reading database ... 315025 files and directories currently installed.)
Removing dnsutils (1:9.16.1-0ubuntu2) ...
Removing libllvm9:amd64 (1:9.0.1-12) ...
Setting up bcmwl-kernel-source ( ...
Removing old bcmwl- DKMS files...

Deleting module version:
completely from the DKMS tree.
Loading new bcmwl- DKMS files...
Building for 5.4.0-26-generic
Building for architecture x86_64
Building initial module for 5.4.0-26-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/bcmwl-kernel-so
Error! Application of patch 0028-add-support-for-linux-5.6.patch failed.
Check /var/lib/dkms/bcmwl/ for more information.
dpkg: error processing package bcmwl-kernel-source (--configure):
 installed bcmwl-kernel-source package post-installation script subprocess retur
ned error exit status 6
Processing triggers for libc-bin (2.31-0ubuntu9) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hi non_space,

I assume you are trying to install a Broadcom driver package?, are you doing it through the terminal only or do you have a .deb package?. :grinning:

Actually not trying to do anything . . . other than "upgrading" via apt . . . . The broadcom error started showing up after I switched /etc/apt/sources.list from "focal" to "devel" . . . trying to get U-MATE to be sort of "rolling" . . . . So in the change from 20.04 to 20.10 that error started showing up . . . . The "dpkg" error is "new" . . . although I thought I saw a post in the "20.04 pre-release" discussion where a gent posted that he had the same error . . . .

Neither one of them appears to be interfering with GUI function, I'm running this machine on ethernet connection . . . . Just reporting the experiences as they show up . . . . etc.

Okay, not really sure but it might be a problem with the dev repo?. If you switch back to the normal Focal repo, is everything okay?.

You might want to file a bug report with the Ubuntu Mate devs?. :thinking:

Normal? Normal doesn't work for me . . . I could switch it to groovy and see how that goes . . . but I have my Lubuntu 201.0 partition running as "groovy" and so far no such errors . . . .

The data I used to try to set U-MATE as "rolling" did suggest there might be some issues between releases?? but their example of the "updates and sources" was from 15.04??? days and didn't exactly match the present GUI sources pages . . . .

It's not causing operational issues, just showing the giant "E" or "error" in the running of apt . . . and no ubuntu "splashy crash" symbol is launching about it. But, if I were to find the need for a bug report, are the "u-mate devs" different than the launchpad bug reports??

Why doesn't the normal standard repo work for you?, what are your repo settings set to?. I assume that sending a message to the Ubuntu Mate devs would also be the equivalent of contacting the normal Ubuntu release devs?.

See the update guide about setting repo's:

What is this "groovy" repo you are talking about?. :thinking:

groovy is 20.10 . . . like focal is 20.04 . . . . Possibly it is "pre-pre-release"??? I don't know, doesn't seem to be radically different than 20.04 in terms of nothing like "900 packages" to update in either U-MATE or Lubuntu . . . .

I have the /etc/apt/sources.list set for "devel" in U-MATE, and it seems to have changed itself so that some are "devel" and some are "groovy."

I have the Lu sources.list just set for "groovy" to test back and forth between the two "20.10" ubuntu partitions that I have installed. So far only the U-MATE "devel/groovy" side is throwing errors . . . .

OK, with you now, I don't think it is a good idea to mix the repo's though as this can throw the system updates off I would assume?.

If you want to use a dev version version of Ubuntu Mate, I would suggest using separate partitions and create a separate root and home partition!. :thinking:

Yep . . . have the separate root and home partitions . . . .

And, the gent who posted this "how to go rolling in ubuntu" . . . did say, "don't try this at home, this stunt is being done by trained professionals . . ." . . . but, just for kicks I thought I'd try it out. I have two rolling opensuse distros and a manjaro . . . rolling seems a tad bit safer than "Sid" . . . . I had a sid system installed and it seemed to tear through the other players files, not it's own . . . had to nuke n pave that one, Sid did not play well with others in a multi-boot situation, etc.

So, I didn't set the file to "mixed" . . . I ran the console command to change from "focal" to "devel" . . . but then after updating i checked the GUI sources and it then showed both . . . again, possibly because we are "between" releases?? But, still "odd" that it would choose to have problems with the broadcom packages????

It is quite possible that the package maintainer hasn't got around to upgrading the Broadcom packages for the next release?. :grinning:

Try taking the tick out of the "dev" repo and run updates again to see if that makes a difference?. :grinning:

Ah, OK on the "maintainer hasn't updated yet" . . . makes sense.

But, what do you mean, "take the tick out"??? In this case they want "devel" rather than "focal" . . . or "groovy" . . . or that was just "humor"???

No, not humour, I mean the dev setting in Software & Updates if that is what you have ticked?. :smiley:

Ah, well, no I didn't have that checked for "groovy-proposed" that is showing.

I have this:

Your problem might lie in the fact that you have multiple entries for "Recommended updates"?, take a look at the properties of those and delete the ones you don't need!. :thinking:

Well, I again ran apt this morning and the only "problem" is the broadcom package . . . .. But as I was looking through the "recommended updates" it seemed like each of them was for something different?? In the components tab one was for "main-restricted," second for "universe," and the third was for "multiverse," . . . it seemed like there was a fourth, but while I was using "edit" to look at the data, the "your software is out of date and must be refreshed" window opened and the "Cache Refresher" bar opened . . . and then wouldn't close . . . it "hung" . . . . then the crash report window opened.

So I sent the crash report and that opened the LP page for bug # 1832057 . . . and that said, "this is a dup for #1829401" . . . so I added my data to the #1829401 bug report . . . because it had happened previously. Then I thought it was because I was a "dual personality" devel/groovy type, but seems like this showed up with focal . . . .

So, that is the problem with looking for . . . "problems" . . . it brings more of them . . . . Anyway, the point is that it seemed like the SOftware & Updates app was "recalculating" on the "recommended updates" material because I thought I saw 4, but now I believe there are three??

You could try resetting APT?. :grinning:

It is quite possible that having multiple entries for the same repo may well be the cause of your headaches?. :thinking:

Right now I'm doing what the legendary race driver Phil Hill said about how he handled difficult crash scenarios with such mastery . . . "I just take my hands off the wheel . . ." something like that . . . .

1 Like

Well non_space, I hope you aren't wearing a blindfold too, that's all I can say really LOL!. :grinning: :grinning: :grinning:

No, no blindfold . . . it's important to be able to "see" the impending stack up . . . . But, other than the broadcom issue, and the "cache refresh" crashing . . . and the, uh . . . the GUI is operational . . . .

I'll try to compare the repo listings between my U-MATE & Lu 20.10 systems and see if there is a radical difference between them, etc. If there is I'll try out your advice and put my hands back on the steering wheel, etc.

If I ever have too many problems with an install, I usually do a fresh install following my own advice which can often be quicker (and easier) than trying to hunt down the cause of a problem. :grinning:

This is not to say that a problem cannot be easily solved, it is just that it can be time consuming finding a solution in the first place, a fresh install can take an hour whereas problem solving can take several hours!. :thinking:

The guide below is intended for people that have separate root and home partitions already set up!. I know you are certainly not a beginner but it is worth a look for anyone reading this thread!. :smile:

1 Like