'Sorry, try again' when entering password on Terminal

Hi folks! So I just started using Ubuntu MATE today and I've been enjoying exploring some of the cool features in this Operating System, I was so amazed how light it runs on my laptop. But I have this one problem that I've been trying to fix on several ways, which is that it would say 'Sorry, try again' when entering the password after using a sudo command on Terminal.

I was suppose to install Flathub when I encountered this problem.
I tried changing my password through the About Me and still it would give the same error.

I'm a hundred percent sure that the password that I entered is right since I can log on to my account when signing out.

Is there possible ways to fix this?

1 Like

Welcome @iglibetario to the community!

1 Like

It sounds like your installation is new and you are exploring the OS.

I would simply reinstall the OS and see what happens. My guess is you are mistaken about the password.

Also, did you have caps lock on?


I never did, and I'm positive that the password I entered is exactly the same since I was able to log onto this account on the lock screen.

you can boot from a live usb again, mount the partition, and change the password. This assumes it is a single boot laptop (not dual boot), it has only one disk (ssd) and the partitions created were /dev/sda1 (/boot/efi) and /dev/sda2 (/). You can find that info if you log on as yourself and issue the command df (does not need sudo) Example:

boot off a live USB
start a terminal
sudo mkdir /mnt/mate
sudo mount /dev/sda2 /mnt/mate
sudo chroot /mnt/mate
passwd yourusername
reboot (remove usb)

In my case, my system has a small partition sda1 for future use, sda2 as /boot/efi, and sda3 as / so I would mount /dev/sda3 to fix the password.


Thanks, I will try that tomorrow! (its night time in here lol)