Sound applet indicator not working - minor annoyance

A recent minor annoyance: sound applet indicator appears muted and can't be enabled (clicking on it does not remove the 'mute' checkmark, sound applet appears fully enabled and all of its tabs do not show errors). Yet, VLC and Deadbeef - despite the mute - happily play whatever I choose.

Card is enabled, and alsamixer -c 0 shows no muted devices, just to eliminate most obvious reasons.

Where should I look for further troubleshooting?

Hi :slight_smile:

Can you check if the correct connector is in use ?
image

I'm thinking that maybe the applet do not control the correct device or its connector.

You can proceed this way to start :

┌─[✗]─[[email protected]]─[~]
└──╼ $aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: chtrt5645 [chtrt5645], device 0: 1 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: chtrt5645 [chtrt5645], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
┌─[[email protected]]─[~]
└──╼ $^C
┌─[✗]─[[email protected]]─[~]
└──╼ $alsamixer 
┌─[✗]─[[email protected]]─[~]
└──╼ $alsamixer -h
Usage: alsamixer [options]
Useful options:
  -h, --help              this help
  -c, --card=NUMBER       sound card number or id
  -D, --device=NAME       mixer device name
  -V, --view=MODE         starting view mode: playback/capture/all
Debugging options:
  -g, --no-color          toggle using of colors
  -a, --abstraction=NAME  mixer abstraction level: none/basic
┌─[[email protected]]─[~]
└──╼ $alsamixer -c 1

Hi Olek, and thanks for the prompt support.

Sound preferences gives me:

sound_preference

(continued - due to 1-image per post limitation)

Alsamixer reports:

with a blinking S/PDIF which does not respond to my attempts to unmute it (blinks for a second, then returns in the off position)

But what challenged me was that in the additional drivers dialog I found that the main sound card appears disabled

so my next attempt is to enable it and reboot (and no, I haven't made any recent change after my initial configuration - and for sure not before this issue emerged)

I'll post an updates, once it finishes

1 Like

Good luck there :slight_smile:

Nope!
I've enabled alternatively both drivers to no avail (naturally rebooting after each change), retried with OEM kernel (4.15.0.1081) as an alternative to present kernel (5.3.0.53)

dmesg is not helping either: after a dmesg|grep audio I get

I'm a bit puzzled...

what about the output of :

aplay -l

aplay -l gives

while lspci -v (pruned so as to include only what's audio relevant) hints that the issue might be an access one (pls see next reply)

Finally found a solution here - amazing in its simplicity: https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Bad_configuration_files

  • rename ~/.config/pulse in order to keep a backup, just in case
  • pulseaudio immediately recreated it, and now everything works as a charm!

By the way, now Sound Settings looks like olek's image in #2 (with connector linked to speakers) and no longer like mine in #3

Thanks to everyone who helped!

1 Like