Sound applet missing after pulseaudio reinstall (solved)

Hi all,
thanks everyone for this wonderful distro. I was hartbroken after Gnomes switch to version 3.x. Gnome 2.x is back- just better!!!

Anyways, I had a problem with audio on a Lenovo G40 which I solved by uninstalling and then reinstalling Pulseaudio. While uninstalling it also removed quite a bunch of packages (cannot remember which ones exactly, it was quite a list). Unfortunately after the reinstall the sound applet from the top panel is missing. I installed indicator sound and indicator sound gtk2, but that didn’t solve the problem. Also, I do not have a sound settings icon in the control panel.

I guess I just have to install some other packages. Any Idea which one?

Thank you very much in advance for your replies,


try the following terminal commands:

sudo apt-get install -f


sudo apt-get update && sudo apt-get dist-upgrade -f

See also:

Hope it helps. :smiley:

Thank you very much for your input, but there are no broken packages on the system, I also don’t want to do an upgrade to 15.10 (yet).

However, in the meantime I found the missing package. By looking at another Ubuntu mate install I found that the missing sound settings app is “mate-volume-control” which is included in the package mate-media-pulse. After reinstalling this package and a reboot, the volume control applet reappeared.

Thanks again anyways,


just to be clear, the above command is NOT FOR DOING A FULL SYSTEM UPGRADE!. :smiley:

Glad you are sorted!. :smiley:

One learns something new every day… Thx. :relaxed:


just for info, this is the command to upgrade the system!:

sudo do-release-upgrade

See also:

Just to finish this thread once and for all:
In the end it turned out that my ssd was not working properly. I got filesystem errors and missing files with various distributions, not just Ubuntu MATE. I ended up throwing the ssd away. All was well afterwards.

1 Like