Sound disappeared on Steam Deck

I have a Steam deck, and one of OS on it is Ubuntu Mate. Deck is known to have problems with audio on various linux distros --- it works only on kernel 6.1+, headphones are quiet, speakers don't work at all. I googled for solution of this problem, and multiple people said that they solved their problems by modifying some numbers in alsamixer. I decided to give it a try. However, the moment I opened sound card in alsamixer, sound (in headphones) disappeared, and i had only dummy sound output. After reboot normal sound outputs returned, but sound in headphones - not. Pavucontrol shows

that output device gets some sound, but nothing is coming out of headphones. Well, nothing from speakers too, but it was like that from the beginning.
Problem is not in hardware, as headphones work ok in windows and steamos. Not sure what to try next, though?

Hi looking at your screenshot looks like you have mute on.

1 Like

no, it is just indicator of a mute burron
when it is perssed (i. e. device is muted) it looks like this

btw, "test speakers" for me liik like this (for both devices)


Another thought launch what is not playing your sound and in Applications Tab of Sound Preferences check.
Here I have a video playing and a YouTube on Firefox.


Edit: just checked and this does not affect Test Speakers so not the issue.

Oops did not register what Steam Deck was. After some research found this

At bottom mentions that possibly Lunar Lobster 23.04 may support the 6.x kernel. It's out might be worth a try by downloading and launching in a live session to see if it helps.


Thanks for your time!
more context:

  1. applications are unmuted

    if they weren't, there wouldn't be a green bar below sound gain here
    [image from first post because new user's can't have multiple images in one post]
    Output device get's sound from system. Just for some reason it does not really outputs it to headphones or internal speakers.

  2. I'm on 6.3.7 kernel already. I'll try to boot with 6.2 kernel to see if it would help, but i doubt it, because sound disappeared some time after i switched to it.

  3. I saw this thread on steamcommunity, and it's not about same thing. Chronology of that thread is as follows:
    a) Steam deck has no sound!
    b) ok, update kernel to 6.1, drivers would appear.
    c) sound appeared, but only in headphones (not speakers) and very quiet!
    d) ok, do some magic with alsa-umc and alsamixer, and it would become normal
    I was at stage (c), and the moment i opened my sound card in alsamixer, sound borked
    and by borked i mean output device disappeared (only dummy output), and when after reboot it reappeared, there was no actual sound from it. So my problem is not their's problem, sadly
    Without kernel 6+ there would not be device "acp/acp3x/etc etc etc" at all.

  4. I tried to boot from live usb to check if just reinstalling would solve my problem. However, when i boot from 23.04 ubuntu mate live iso, there is only dummy input and output, and all solutions that tries to fix it without reboot did not help. So i'm not sure what happens there either. aplay -l shows same as if i use it from installed OS, i. e.

deck@Steam-Deck-Monroth:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 7: HDMI 1 [HDMI 1]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 8: HDMI 2 [HDMI 2]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 9: HDMI 3 [HDMI 3]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: acp5x [acp5x], device 0: Playback/Capture nau8821-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: acp5x [acp5x], device 1: CS35L41 Stereo Playback multicodec-1 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 2: U192k [UMC404HD 192k], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

(don't pay attention to U192k, i borrowed this external card ANYTHING will output sound on my ubuntu system. And yes, it outputs sound)


just booted with regular ubuntu mate 23.04 kernel (6.2.0-20-generic)

and as i expected still no sound from onboard sound card


Quick question no sound at all? Play movie on Desktop sound ok or just no sounds on items controlled by Steam Deck.

1 Like

not sure what you mean by "controlled by steam deck"
as far as i tested no sound while in ubuntu and without external sound card
on windows and steamos sound is fine
also as seen on first screen even in ubuntu everything on the way from applications to "output device" in pavucontrol is fine too
something strange happening inside this output device (and hence strange "test speakers"), and i'm not sure why or how

1 Like

OK sorry this issue is beyond the scope of my knowledge.