Sound issue through headphones - baffling

Wired headphones. Music plays from Google play, speaker test working OK, alerts, screenshot sound etc all come through headphones OK so it's not a jack issue.

All sound works well through the speakers but cannot get GNOME MPV or VLC or even YouTube to bring sound through the headphones.

System information attached.

Thanks in advance for suggestions on how to fix.

sound sound%202 system

I normally install pavucontrol and use that to tweak wher I want each application sound to output. The built in tool doesnt have all the options I find.

Thanks pallebone.....

I am somewhat of a newbie so trying to keep everything simple. Would assume would have to load from PPA?

Also, this only started to happen since the last update so really not sure why so hoping UM folks can comment as well.

1 Like

i'm pretty sure you just need to

sudo apt install pavucontrol

Ahhh....much easier. Thanks MusicalCoder!

1 Like

Ok, PulseAudio loaded and working however issue not resolved with YouTube (tried changing browser from FF to Brave, no change).

Downloaded a video file of my own to desktop. No volume through GNOME MPV or VLC. Nothing.....

Google Play streaming through browser works fine through headphones. Listening to tunes clear as a bell.

Still baffled!

run pavucontrol from the terminal or in your menu search for pulseaudio volume control and when you open it you can select the output for each app such as:

In this example I have changed speech-dispacher from my headphones (razer kraken) to built in audio from my laptop. You can change volume per app or mute/unmute by clicking the volume button next to the lock etc.

Send a screenshot of what you see with the video playing if its not making sense.

Kind regards

Thanks Pete.

Screenshot attached. Still no sound through headphones from GNOM MPV and hitting the sound icon only mutes it. Lock only groups the channels.

I cannot seem to be able to choose the output for each?

If you go to the configuration tab can you post a ss of what is listed there? Also the output devices tab. normally if you cant select a different output device then its not seeing more than one valid option (so it does not offer the ability to change).

strange, is this your monitor that you are outputting sound from (lists HDMI as an output on that list) if so there is a headphone jack on the back of the monitor you should probably try.

MacBook Air. Headphones plugged into side of base as normal.

The strange part is that as stated this worked perfectly last week before doing some updates. Google Play and other streams work fine but YouTube and local files don't work???


what if you move the slider under output devices up from 15% to like 100% while sound is supposed to be playing? Perhaps something will get kicked back into life. Analog stereo output sounds good for the setup you have described. Analog stereo duplex would be for if the headphones have a mic on them.

I have tried that. I DO get some crackling but it still does not work.

I have rebooted as well wondering if the updates needed that.

under output devices for the port dropdown list, what other options are in there?

Speakers....which when headphones plugged in has (unavailable) next to it.

Yes try changing it to that anyway.

Just shuts down my headphones....just tried it as I was listening to music and now silence.

Tried the video files, nothing. Nothing on YT.

Appreciate all the assistance....keep the ideas flowing but when you get frustrated and ready to quit, I will understand. To me.....Something isn't right in the code.

hmm, I am trying to lookup some suggestions on the net, one option is to try:

alsactl restore

from the terminal.

Also maybe

sudo alsa force-reload

if the first option was no help.