Standard screenshot app won't work while main menu is open

I just tried to take some screenshots of my main menu to demonstrate a point in a discussion in this forum (here to be precise), and it turns out that the Print Button doesn't do anything while the main menu is open. The I tried to put an app launcher for the screenshot app into a panel and use that, but the app launcher doesn't work either while the main menu is open.

That is 100% correct.
The whole desktop environment consists of one eventloop which is single threaded.
This is a result of designchoices that were made long long ago and which is not fixable without completely rewriting the complete desktop environment.

The result is that the desktop can only do one thing at a time, either showing a menu or starting an application but not both at the same time.

There is, however, a nice workaround:


Another workaround is to use Gnome Screenshot which does allow delay.
In example
1 Press Selection
2 Set a delay may take a couple of guesses
Sweep select roughly the area you want to capture (open menu and visualize.)
Press 3, sweep select roughly same area, then open your menu which resulted in 4.
Not using Gnome or Mate, and 5 shows bad guess of area cropped out.
I used Ksnip Continous Appimage to create this image showing Gnome way.
Actually opened another instance to capture the initial screen.
Like Ksnip as it allows opening an existing image also. Save image and decide want to add some more annotations.
Another option people like is Flameshot, but after saving can't open for further operations.