Start with Ubuntu Mate "Bionic" 18.04


#1

822/5000
Hello,

The installation of Ubuntu mate has been easy with Bionic 18.04, until the first update, from there, many complications arise, black screen, impossible to start the operating system. I have micro rizen 3 2200G with integrated graphics, I put the following commands in the grub: “radeon.si_support = 0 amdgpu.si_support = 1”, updated the graph with the padoka page. Then I changed the orders in the grub, as they indicated to me in Ubuntu Forum (I did not have answers in Ubuntu mate wiki) to: modeset amdgpu.dc = 1 acpi_osi = “Linux”, each start is complicated I continue with black screen after the ubuntu icon mate, and I can not enter the operating system It stays locked. I want to update the kernel to 4.17, which they say: it brings improvements to the graph, but I can not enter.

I would be very grateful if someone can help me.

My mother card is Assus X370M Pro4
Logs: deskstop Kernel: (drm:amdgpu_init (amdgpu)) ERROR VGACON disables amdgpu kernel modesetting.

Deskstop Kernel: ACPI: Error: (PTOS) Namespace lookup Failure . AE_NOT_FOUND (20170831/PSPARSE_364)

Deskstop Kernel: ACPI: Error: (PTOS) Namespace lookup Failure . AE_NOT_FOUND (20170831/PSPARSE_550)


#2

Can you boot into your system at all?

You definitely need a newer kernel, probably 4.18 or 4.19 or later. I don’t know about padoka’s AMD drivers as I use obaif.

The kernel options:
(1) amdgpu.dc=1 doesn’t do anything as this feature is already enabled for Vega GPU (like what is in your Ryzen).
(2) acpi_osi=Linux is probably not useful, possibly breaks a great many things.
(3) radeon.si* amdgpu.si* shouldn’t be needed. If it is really needed then there is some other problem with GPU identification.
(4) nomodeset prevents any of the radeon or amdgpu drivers from being used.
(5) Until you are sure everything is working, delete the “splash” and “quiet” options.

The root of the problem is probably iommu settings which are not working in the stock 18.04 kernels. It is probably best to go into your BIOS and disable iommu at least until you get a much newer kernel loaded.

If you can get back to a stable stock 18.04 installation then you can build from there. I would use obaif

https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

drivers. If they don’t work you can back them out with ppa-purge.

Check

https://wiki.ubuntu.com/Kernel/MainlineBuilds

for instructions to load a newer kernel.

djb


#3

Thanks Dave for your response. After removing the parameters from the grub: amdgpu.dc = 1, acpi_osi = Linux, radeon.si * amdgpu.si *, nomodeset, splash and quiet. I did not find to disable in the bios iommu, but aparatentemente according to the logs of the system loads them well. And to uninstall the Padoka drivers and try to reinstall those of Obaif (without success) (I do it remotely because it is a computer of my cousin that is in another city) when restarting it loads up the logo of ubuntu mate, from there the screen is blocked. There are already many attempts so I decided to wait for the new stable version in February to reinstall the operating system. Thanks for your help.