'Starting Caja' Loop

What version of Ubuntu MATE?

It does sound like there are some config settings on your user folder that are stuffed. Hence the guest user’s settings being okay.

That being the case, is it possible to create another user with a name similar to yours, that can be the “new you”? Then, log in as this new, uncorrupted user and delete your old (corrupted) user account (making sure to back up and copy any personal files to your new user folder, of course).

Latest one, did a dist-upgrade yesterday

No window. Is there a way to do that through log in? Ok, this reboot I have a cursor, still no windows or tilda

I am in Australia, need sleep so will respond in 8 hrs from now

If you have a normal cable network connection, run “dpkg” per the update guide in “Recovery Mode” (Advanced options):

A dist-upgrade is not a version upgrade.


To check your version in terminal…

inxi -S

That looks like a great way to fix it but now I really feel like an idiot.

I remember after first installing disabling grub screen either completely or dramatically reducing display time for sake of speed so now I’m not able to access it. Is there a sure fire way to access it?

Have I painted myself into a corner?

When I am able to get a cli, I will do that

Sorry, that happens when I get in a rush.

At the boot screen or at the login screen you can go to console by pressing Ctrl+Alt+F1 and log in. Console is a text only terminal.

It might be possible to access Grub by pressing the “Shift” key as soon as your PC boots?. :smiley:

Tried shift key, no go unfortunately

Kernel: 4.2.0-30-generic x86_64

Cool, Thanks, didn’t know that one. Kernel: 4.2.0-30

Ok, your running Wily.

Two things to try in console to restore GUI:

1-Press Ctrl+Alt+F7; this will try to take you to your desktop. If this fails, press Ctrl+Alt+F1 to return to console.

then try

2-While in console enter the command


That may take you to the desktop (GUI).

Wimpy may return, but till then @stevecook172001 post should also work.

Ok, I restored the grub screen by following this guide: How to show grub menu in Ubuntu with only a single OS installed but using nano instead of caja because caja will not start on my system.

So I have completed the ubuntu mate update guide dpkg in recovery mode step

I can get to the desktop but the only thing that opens are menus, no windows actually open or perhaps are not visible. multiple instances of caja still opening but no windows

Is there a way to go back to default gui setting via cli? I’m no expert but that is where I believe the problem is.

Sorry stevecook172001 , didn’t repond to your suggestion and am locked out of more replys for 24 hr period, yes I believe you are right, will try to do it from cli with googles help.

Normally I would usb boot, copy data, nuke and pave when I get in a situation like this, but I need to learn to fix it as you suggest, would certainly be faster.

How did you do your initial install?, was it a disk or USB install and did you burn the disk at the slowest possible speed and/or; did you fully format the USB stick?, I ask because you seem to have multiple problems and this may be due to read/write errors when you created your bootable media?. :confused:

Ah sorry wolfman for the answer delay. It’s on a Nuc so usb install, yeah a formatted usb via gparted. I was just getting on to say that I have created another sudo user, migrated all the data making sure not to include configs. then deleted original sudo user. From now on all my config experimentation will be in a virtual image!

1 Like


try running the following terminal commands which may/may not solve any problems for you?:

sudo apt-get --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get --fix-broken install

The above command downloads and installs any broken dependencies on your system.