Still - TOR won't install - too many errors?

I tried installing TOR via boutique, that failed - see screen cap below. But checking, found it did install but just won't start so uninstalled that, rebooted, tried installing via Terminal, and both times, same crash result in:

I read about similar issues, none the same for 18.04.03 clean install. My issue is won't install.

And if you install via the website?

Thanks Aegir81 the Tor dload tip, but now, for the fifth time, Ubu NOT I, has again lost my password. If there isn't a quick way, I'll need to re-install Ubu again, update it again, re-do all settings again etcetera - - - for the LAST TIME. Arggg!

How do you mean? How did Ubuntu lose your password? Reinstalling for the fifth time feels like overkill.

You will have to ask Ubuntu that.

This is all I can tell you...

  1. Works fine for a while
  2. Click the computer icon - click Shutdown > Click Shutdown again.
  3. Go to bed.
  4. Get up - press Start button on laptop - systems starts it's load.
  5. Password prompt comes up - as usual. Enter password. Hit ENTER: Error dictates it is the incorrect password.
  6. Retry, still won't take it.
  7. Check if keyboard layout is correct - all is good.
  8. Check for lower/cap settings - all is good.

Do I know my passwords? Better than Ubu does.

When I say 5th, it has happened 5 times at random times in over a 1 year period.

I'm not sure how, or whose tip I used, but was able to reset the password by pressing suggested key combo at boot and doing some listing of users and password reset there. Sorry, I can't remember which help it was, and am trying to figure out so I can thank them.
Once logged in, I have had a lot of other things to get done but will look and thank them.

I will also keep a print-out of how to reset the password. I have disabled screen saver and suspend from requiring a password. Not safest way, but I'm in, as they say. It's a good feeling to see Ubuntu show up. But this topic is / was about Tor not installing properly.

BTW, I found there is another user, that being my Windows desktop. How I did that is another mystery. It's possible it was trying to log me in as the other user, that being the user on my desktop (probably from when I tried to network them.)

Many thanks Aegir81 for your invaluable time and experience - I very much appreciate it.

Finally got time and I tried your suggestion. It pretended to install, but the icon showed up so I gather it installed, but clicking - nothing happened.
Then I read this on Github, but either they are expert Linux users, or like to show off. None makes any sense.

After 22 minutes, a window popped up saying it was installing and beside it, said "Not Installed" and closed on their own. After another 20 minutes or more the same screens popped up as in my first post (above top).

I also removed it rebooted, then tried the steps here. Same thing. A very long time to cough up anything - I'd be happy if were a fur-ball - it's something :slight_smile:

As I type this, now it's more than 40 minutes since trying install, this popped up again.

It hangs at this for about 20 minutes, then the all is quiet for another 20 or minutes, the install failed due to key. Like start of my post above.

Here is something I think may be odd. If I "Edit as Administrator" the desktop Tor icon/label, I read this:

[Desktop Entry]
Name=Tor Browser
GenericName=Tor browser
GenericName[hu]=Tor böngésző indító
Comment=Launch Tor Browser
Comment[hu]=Tor böngésző indító
Exec=torbrowser-launcher %u
StartupWMClass=Tor Browser

It appears Chec , Russian or Spanish, but it's all Greek to me. I just followed the links and ideas.

Thanks @Aegir81,