Strange behavior after installing NVIDIA GT 1030 card

For about two years I’ve been using my Gigabyte GA-Z97M-D3H with onboard graphics on various Linux distributions and last year settled on Ubuntu MATE.

It worked fine, but I knew one day I’d have to get a dedicated GPU. So I got a NVIDIA GeForce GT1030 (the actual model is Gigabyte GV N1030SL).

I decided to do a fresh install of Ubuntu MATE and noticed right away that when booting from USB various errors were reported on the screen. I did not get the actual messages, but they had something to do with UEFI and Nouveau. Anyway, the installer loaded, but the resolution got stuck in 1024x768. I went until the end of the process hoping to load a proprietary driver after install, but the NVIDIA stuff that is loaded does nothing for me in this regard. I searched online and found some posts about the monitor not being able to inform the hardware the resolutions it is capable of, but the recommended utility to solve it was Windows-only. EDIT: Actually, in this state, NVIDIA X server settings doesn’t offer me anything with regards to monitor. It just seems to find a generic monitor which can’t be configured.

Then I tried switching from HDMI to DVI and at first it worked, but then I tried a reinstall (for another, un-related reason), and it went back to 1024x768. I tried it all, messing with UEFI Setup, reinstalling hardware, installing other distros, all to no luck, until I reinstalled Ub Mate with low-res on HDMI and then turned it off, switched again to DVI, and then got 1080p automatically.

What bothers me is: first, the same way it came, it can go (stop working) for no apparent reason; second, the messed up installation. After it finished, on the “Remove installation media and press ENTER” screen, it was looking like there was a command line prompt on the background, with blinking cursor that jumped lines if you pressed enter and all. Needless to say, I had to actually push the reset button on the case to get the computer to restart.

Any ideas?

Some further info on my system:
Monitor is LG 22MP55
Ubuntu MATE 17.10 (installed on SSD)
Intel Core i5 4690k

After this last install yesterday, I went to get some sleep e put the system on Suspend. When I got back to it, several hours later, after hitting the space bar to wake the system, the LEDs on the case lit up, but the monitor stayed as if receiving no signal until it went on power saving mode again. Had to hit the physical reset button and restart. Then I noticed that the startup Ubuntu MATE screen shows up in 1024X768 and only on the login screen we get to 1080p.

Hi fredmbarros,

read from “System Update:” and run dpkg in recovery mode: