Strange behaviour program starter top panel

Since the last program update some of my program starters in top panel show up a strange behaviour.
The normally will show a folder (wish contains files / folders).
This has work well but not now...
When I click such a program starter in the top panel Handbrake start up...
If I move the 'starters' 'down' to the desktop they behave normally (show the expected folder).

Any ideas?

My system:
terminal code: uname -a
Linux nisse-u20 5.8.0-53-generic #60~20.04.1-Ubuntu SMP Thu May 6 09:52:46 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Welcome, @NilsGN, to the forum. :grinning: :ubuntu_mate:

If I'm understanding this correctly, you're saying that now the launchers on your top panel that used to open a particular folder:


...instead open the HandBrake program, which is this (to ensure we're talking about the same program):

...but if you drag the launcher down onto the desktop and then double-click on the icon on the desktop, the folder is opened like it's supposed to be:

Does HandBrake open up to that specific folder that you wanted to open in the normal file browser, or does HandBrake just open to no folder or multimedia file in particular? This is awfully strange that a system update would do this.

In two of three cases handbrake show (in a 'small' window), the content of what the folder contain, like if You look at the folder from the Terminal after command 'dir' or similar.
Black background and White text.

Wow! This is unbelievable.

OK, click on a launcher on the top panel to open HandBrake, and use the Screenshot tool (search in the main menu for "screenshot" or whatever it might be translated into your native language) to show me what this HandBrake window looks like exactly. I can't find any information about why HandBrake would do this.

I'd ask you for other screenshots, but alas, a new user like you cannot upload more than one picture in a particular post (to prevent spammers from causing a lot of damage).

Ok here it comes:

I have click on a program starter in top panel and the path is:
and Handbrake show a bit of a file named:
The first file in the folder.
And it do this trough a soft symlink.

I Install a version of Handbrake from: ppa:stebbins/handbrake-releases
I now remove it.
And install the Handbrake version from snap-store
And the strange behaviour is gone...

Shall I state this issue as [SOLVED]?

I marked it as solved for you since there's really no telling what a PPA is going to do to your system. (OK. Maybe not no telling, but it's not always clear that a PPA release is bug-free.)

I'm glad to hear that you solved it. :+1:

FYI, I've seen this bug before: I don't really remember the specifics too clearly, but something (I think it was VLC in my case) had decided to associate itself with folders.

I fixed it by editing ~/.config/mimeapps.list and changing the inode/directory= entry to caja-folder-handler.desktop

Removing the PPA has obviously fixed your scenario, but the method I mentioned should let you reinstall it if you want without it borking your shorcut, hopefully. :slight_smile:

Thanks! :slight_smile: