Stuck at Login Screen that will not accept my password!


#1

Hello all,
Sorry to be a pest this week, but I have another issue, and I’m hoping you folks can help!
Here’s what happened…
I was using LibreOffice on my Desktop PC, which is running Ubuntu Mate 18.04. I was just editing a 20 page document, when I suddenly received an error message. It was telling me that I was out of memory in a backup folder for LibreOffice. I went to the folder it showed me ( I cannot remember the path) but I did not want to risk losing my file. Another message came up saying I was running out of space in another folder ( I cannot remember which one) and that I needed to empty the Trash. I did so but LibreOffice was still giving me the same message and I could not close it. I figured the program had crashed and I could not locate the process in the System Monitor to end it. Maybe it was a wrong move, but I decided to reboot the system.
Now I’m stuck at a login screen with green wallpaper. I have three accounts on this machine and I cannot log into ANY of them! I’m told my password cannot be accepted. I have a USB Stick with Ubuntu Mate on it and can boot my system into “Try before you install mode”. I was able to make a quickie backup of my essential files. I can use that trick again to gain access to my system. Does anyone know how I can fix this problem? Do I need to change my password? If so, How? I just need access to my central account, the other two are guest accounts with nothing important.
I’m receptive to any and all ideas right now, just trying to avoid reinstalling everything!
Thanks in advance for all your help!

P.S. This problem persists through repeated reboots, and I don’t think it’s a keyboard issue. I will try a few more keyboards from my junk bin to make sure!


#2

boot your system (hold SHIFT) and select recovery on the grub menu, then select root shell access. your prompt should be # Type, mount -o rw,remount / for your disk to be RW, then type passwd panic (or whatever your username is) and give it a pw. After success, type exit, system should reboot and user panic should have a pw. Then, you can fix the other accounts.


#3

First and foremost, I want to thank you for responding!
However, I have run into a snag…
Holding down either the left or right SHIFT key does not get me to the grub menu. If I hold Esc I can get to a grub prompt and can use the TAB key to list possible commands, but none of them get me to recovery mode.
I tried using my installation USB Stick to boot into “Try before you install” mode. I was able to get into root in the the terminal. However, it dawned one me that I was “talking” to the USB Stick and not my hard drive. I could not figure out how to switch drives so that the procedure you gave me would work.

I have tried booting the system with other keys held down to try and access the grub menu, but nothing works accept the escape key. I f you have any other ideas, please don’t hesitate to share, and thank you again for taking the time to help me out, I do appreciate it!


#4

If I understood, you get the grub line to boot a kernel, are you able to append to that line (next to quiet splash) init=/bin/bash and let it boot? if so, it will boot to a root prompt, then passwd panic, set your pw and reboot.

There is another option using the live usb where you can mount your drive (sda) and other things, then chroot into that environment and fix it. I will look for the details …


#5

I’m not sure I follow you…
The grub prompt I get does not bot into a kernel or anything else. Here is what it it says on my screen:

GNU GRUB version 2.02
Minimal BASH- like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device completions.

grub>

When I hit TAB at the above prompt, I get a whole wall of text with commands. Too many to list here, and I’m unable to take a screen shot at this time.

I do see two commands that might help: legacy_kernel and legacy_password but nothing happens when I type them in. I think I need to pair them up with something according to the message at the top of the screen but I’m not sure what combinations would work.

I’ve been doing research on my own but everything I find is either outdated or simply does not fit my situation. Sounds like you may be onto something with the live usb, i look forward to seeing what you can come up with.

Anyway, thank you again for all your help!


#6

lots of reading, the one marked with 24 votes has 8 steps to do the chroot.
Please read from the top and hopefully one of those methods will work.


#7

Okay, great!
Thank you!
I’ll dig into it after lunch and let you know how it goes!:slight_smile:


#8

Well… I gave it my best try… I read through that whole file.
I tried as many procedures as I could, but I still could not resolve my issue.
Almost all the methods were contingent on holding SHIFT during boot to get the grub menu to appear on screen and choosing recovery. I just could not get this to happen! Holding SHIFT did nothing.
I have gone ahead and re-installed Ubuntu MATE and am in the process of restoring all my settings.
Thankfully I was able to back all my personal data up.
I have bookmarked and generated a partial print out of the stuff you sent me.
Maybe if I run into this problem again it will come in handy!
I should be back to “normal” in couple days.
At any rate, I want to thank you once again for all your help!


#9

It sounds like your root partition ran out of storage space, like literally 100% used, 0 bytes free - which can cause weird behaviour like being unable to login. An alternate may have been to try logging into the console (like a terminal) by pressing CTRL+ALT+F1 at the login screen. This might at least give you the ability to confirm if that was the case:

$ df -lh

Filesystem      Size  Used Avail Use% Mounted on
/dev/sda2        59G   59G   0  100% /

It seems unusual that holding SHIFT didn’t bring up the GRUB menu, next time you could try pressing SHIFT repeatedly in case your BIOS was ignoring the held key presuming it was “stuck”. A more brutal way could be to interrupt the boot process multiple times (as in hard reset or repeated presses of CTRL+ALT+DEL) as I think the GRUB menu will appear after a few failed start-ups.

:bulb: Tip: It may be an idea to consider imaging your system, like with Clonezilla, to save time from having to do a full re-installation if things go wary again.


#10

Thank you for your reply!
Until recently I was messing with Timeshift and the built in back up utility. However neither seemed to work reliably. Clonezilla looks very promissing! I have an external hard drive in one of my junk bins I should probably dig out and set up. No excuse for not doing this, just laziness. Although, I was able to get back on my feet in under 2 hours this time. I’m a bit of a hoarder when it comes to games and other non-essential crud, so a purge like this was probably a good thing!
I’m going to copy down and save the procedure in your post for future reference, just might come in handy someday!
Also, I agree that it was rather odd I could not get the Grub menu to come up when all the instructions I read said that was the thing to do. So again, maybe a purge and re-installation was not so bad after all.
I’m really glad this forum is here, really would feel totally lost without all of you!