Stuck on restart after migating harddrive

I’ve installed and configured Mate on laptop A. Last week I switched to laptop B.
And now mate hangs on restart. Shutting down is no problem.
Both laptops are Asus, with intel processers and nvidia cards.

I ran sudo update-grub & sudo update-grub2

That didn’t help.
Any suggestions?

Hi @janw.oostendorp,

run the following command:

sudo apt-get remove grub-pc && sudo apt-get install grub-pc

then try rebooting!.

The following commands won’t work as Ubuntu Mate is using grub-pc!. :smiley:

sudo update-grub & sudo update-grub2

It hangs and will not restart or hangs then restarts??

I ask because different trouble shooting methods are used.

I like to see what is hanging up. Take a look at the boot processes (if you can) in terminal:

systemd-analyze blame

If you cannot boot into your system, can you get to console at login?


@wolfman[quote="wolfman, post:2, topic:11350"]
The following commands won't work as Ubuntu Mate is using grub-pc!. :smiley:

sudo update-grub

This command (sudo update-grub) has always worked in MATE for me. Where did the idea that it doesn't work come from Wolfman? Just curious... And my Synaptic shows this:

HI @mdooley,

the sudo update-grub command doesn't work in live mode (maybe I should have started with that!):

I also seem to recall that using the grub-pc fix works for me!. :smiley:

Of course. Thanks Wolfman. I didn’t know you were referring to a live mode session.

1 Like

Hi @mdooley,

I cannot explain myself correctly sometimes because I have health problems (I won’t go into detail) which may well cause confusion, but it isn’t intentional I can assure you!.

I am not really sure if he is trying to run that command in live mode but it hasn’t worked for ages, the other option might be to use “Boot Repair” maybe?.


have you tried “Boot Repair” using the live CD?, see the update guide section on repairing Grub and using welcome:

See also:


I’ve tried the bootrepair utility and reinstalling the grub-pc
It didn’t help.

In the end I now have a default grub screen (only with the mate gray instead of ubuntu purple).
And I have all these nonsense boot options.
Any easy ways to restore those?


It’s stuck on a black screen. And it responds to nothing. It does show the mate logo as it’s closing.

The grub repair report after using the repair from a live-usb.
Also after rebooting from the usb it asked to remove the drive, so I did and after that it also got stuck the same was as no native reboot.

I am not familiar with EFI, someone else will have to assist. Good luck

Hi @janw.oostendorp,

you have no boot-loader installed to your HDD, it is installed on your USB stick?:

=> No boot loader is installed in the MBR of /dev/sda.
=> Grub2 (v2.00) is installed in the MBR of /dev/sdb

I ran this from a USB, But mate is installed on /dev/sdb.

/dev/sda is the build in hdd.

Is a report running from the installed drive helpfull? I also tried that, but didn’t help.

You need to tell us as to whether you are trying to run your system in persistent mode (from a USB stick) or do you want it installed to your HDD?,

If you run Boot Repair again, make sure you click on "Advanced options" and direct the boot-loader to /sda!. (Bottom left in the picture below) :smiley:

The pastebin report is when I ran boot repair from a USB, you recommend running the boot repair from a live-CD. I used a USB stick.

/sda is the build in harddrive (windows)
/sdb is my own migrated harddrive where Mate already was installed. ( it also has a Windows installation which I will delete some other time, not part of this thread)

Thanls for keeping up with me @wolfman

All I can suggest is that you run Boot Repair again and do as I suggest and direct the boot-loader installer to /sda (which should be where the Windows boot-loader is)!. :smiley:

Another suggestion just hit me, you can swap the drives around, I assume that you currently have 2 HDD’s (is that correct?), open the PC casing and make the first drive inot the slave and the 2nd drive into master, that way the drive with your Ubuntu install will become /sda and the one with your Windows install will become /sdb.

If they are older IDE drives, you need to swap the master jumper on the drives around, make the current master a slave and the current slave into the master!. :smiley:

So I ran boot repair and added sda1 as the location.

It didn't help :frowning:

I can't switch the drives. It's a laptop and it happens too have room for a second drive.
Too reach the first drive I have to open it completely and warranty and all.

Do you have other suggestions or will I just have to live with it?

Hi @janw.oostendorp,

well the first thing I would do is check what your UEFI settings are, do you have "Secure Boot" disabled?, are you using "Legacy Boot".

In the pic above and where it states "OS to boot by default", did it have any other options that you could select?. :smiley:

If you scroll down to section 4 of the partition guide, you will find some info about UEFI. :smiley:

If you have all your data backed up, you might consider using the "Something else method" to do a fresh install?:

When you get to this window, be careful where you put the boot-loader and also watch what partitions you format/use:

I really appreciate the effort. But I’m giving up.
On a week off I’ll might try a full reinstall, and read section 4 before starting.

For the record.
Secure Boot Control is disabled
Legacy USB Support I tried both enabled and disabled no difference

1 Like

Hi @janw.oostendorp,

good luck and keep us posted!. :thumbsup: