super+T no longer loads preferred terminal: Tilix -- post upgrade

Hi all. Recently I upgraded to 19.10. Post upgrade super+T key combo no longer loads my default, preferred terminal: tilix. Tilix was still set as preferred termal app. I also re-specified it under:

sudo update-alternatives --config x-terminal-emulator
[sudo] password for steve: 
There are 6 choices for the alternative x-terminal-emulator (providing /usr/bin/x-terminal-emulator).

  Selection    Path                            Priority   Status
  0            /usr/bin/tilix.wrapper           30        auto mode
  1            /usr/bin/koi8rxterm              20        manual mode
  2            /usr/bin/lxterm                  30        manual mode
  3            /usr/bin/mate-terminal.wrapper   30        manual mode
* 4            /usr/bin/tilix.wrapper           30        manual mode
  5            /usr/bin/uxterm                  20        manual mode
  6            /usr/bin/xterm                   20        manual mode

Press <enter> to keep the current choice[*], or type selection number: 

so my "preferred" and alternatives setting currently match. I also tried re-installing tilix to no avail. Why does super+T still load default MATE Terminal? I'm stuck.

I'm on a thinkpad t-450s


So as an aside, if I switch the terminal keyboard shortcut to the alternate (CTRL+ALT+T -- which I don't want) via the keyboard shortcuts applet, this all works. Somewhere 19.10 trumps keyboard shortcut applet with a default Super+T setting.. where is this? Also another test, which further vets this.. if I add a custom shortcut for Super+T to run tilix.. I end up with two terminal windows.. 1 for Mate Terminal and 1 for Tilix.

You can change this using dconf-editor

Go to org>mate>marco>keybinding-commands>command-4
Switch the radio button to off for Use default value
Change custom-value to tilix

1 Like

Thanks so much Frank! You Rock!

The non-GUI way for people who wish not to waste space with dconf-editor:

:heavy_dollar_sign: In x-terminal-emulator:

gsettings set org.mate.marco.keybinding-commands command-4 'tilex'

Replace tilex with preference. (In my instance, I chose x-terminal-emulator.)


Thankful this thread was still here.. setting up a vm with 21.04 and needed to do this again. btw.. tiox, you had a typo in yer cmd.. it's "tilix" :stuck_out_tongue: But thx for adding!

Very welcome. It's just supposed to be an example anyway.