System broke after update

Hi once more.
After recently updating my computer, I came back to find the screen frozen on the Ubuntu-MATE welcome screen. After restart it, I got an error message which said something like “Kernel Panic: Not syncing: VPS: Unable to mount root fs on unknown-block(0,0)” (I can also post a screenshot if anyone needs it). I have tried live booting the machine and checking the hard disk and files on it and everything seems to be fine. I tried loading an older kernel which seemed to work. However, the back of the welcome screen was black and I couldn’t get an internet connection (without some command prompt work).

Just before updating, I added the artful repository which may have introduced newer or unstable software to my system. I did this to install a newer version of a program but it seems that it has done the same for everything. Prior to adding the new repository ppa, I only had xenial ppas in the sources.list.

So my question is: What can I do to get my system back to normal? Do I need to rollback the update? If so, how?
Thanks in advance for any help with my problem.

You basically upgraded all or most of your system to 17.10 beta. There’s no safe way to downgrade, so your best bet is reinstalling. Could be a 17.10 (artful) error, or could be due to improper updating.

Let"s hope he kept his home directory separate.

@PizzaDude Thanks for replying. I figured that I could reinstall my system, but that would be my last resort, as it took me months to set up the system to be how I wanted it and do not want to repeat the process if I don’t have to. So what do you think I should do? How could I roll back the update? And also, if i do, how do I add a ppa that only allows one program (and its related packages I suppose) to update and not the rest of the system?

@tiox Let"s hope he kept his home directory separate.

What do you mean by this? My home directory is on the same partition as the rest of the system, except for the swap partition, and the hard disk isn’t corrupted or anything. So what do you mean?

@rcdronan I think @tiox means it would be easier to reinstall if you kept your /home directory on a separate partition, but it’s not needed. If you were to reinstall now you would have to back up the stuff you want with a LiveCD and reinstall.

For what it’s worth, I don’t have my home directory on a separated partition either.

But I just thought of something.

Maybe you only upgraded partially, which would mean instead of trying to downgrade (which isn’t a good idea and can cause even more problems, and to be frank I don’t know how to do it), you should try and upgrade fully.

Can you post the contents of your /etc/apt/sources.list ?

And then we can go on from there.

@PizzaDude Here is the contents of /etc/apt/sources.list:

# deb cdrom:[Ubuntu-MATE 16.04.1 LTS _Xenial Xerus_ - Release amd64 (20160719)]/ xenial main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://nz.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://nz.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://nz.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
# deb-src http://nz.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://nz.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://nz.archive.ubuntu.com/ubuntu/ xenial universe
deb http://nz.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://nz.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://nz.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://nz.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://nz.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://nz.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://nz.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://nz.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse



# New Minetest version
deb http://cz.archive.ubuntu.com/ubuntu artful main universe

Remove the last line, type this:

sudo apt update

sudo do-release-upgrade -d

This will upgrade to Ubuntu 17.10 beta. You need to do this since you partially upgraded. You will no longer be on long term support until 18.04 comes out and you can upgrade to that in 2018 after and stay on it if you want to keep LTS.

If the upgrade fails because of low disk space, clear some space and try again.

If it fails for any other reason, post the output here.

Also, before you do anything like this again, not to be mean, but there’s a Minetest ppa.

@PizzaDude I tried but I get an error message:

[email protected]:~$ sudo do-release-upgrade -d
[sudo] password for user: 
Checking for a new Ubuntu release
ERROR:root:parse failed for '/var/lib/update-manager/meta-release-lts-development'
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/UpdateManager/Core/MetaRelease.py", line 240, in parse
    while index_tag.step():
apt_pkg.Error: E:Unable to parse package file  (1)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/UpdateManager/Core/MetaRelease.py", line 374, in download
    self.parse()
  File "/usr/lib/python3/dist-packages/UpdateManager/Core/MetaRelease.py", line 278, in parse
    self.METARELEASE_URI)
UpdateManager.Core.MetaRelease.MetaReleaseParseError: Unable to parse http://changelogs.ubuntu.com/meta-release-lts-development
Upgrades to the development release are only 
available from the latest supported release.

@PizzaDude @tiox
While waiting for a reply, I tried to open the package manager and got an error message. I ran the command
sudo dpkg --configure -a
and it seemed to fix some things. The computer now starts up without trouble and the login screen seems to have changed and is no longer black. I am still having internet connection problems and may be having audio problems too, but this may just be application specific or because of my lousy speakers. Do you have a solution to my error message yet @PizzaDude, or will I need to seek help to my problem elsewhere?

@rcdronan I got lazy and forgot to answer sorry.

Try upgrading by changing every instance of “xenial” to “artful” in /etc/apt/sources.list and do sudo apt update && sudo apt dist-upgrade

Perhaps it would be better to remove the offending artful ppa using ppa-purge and then do a system update and upgrade. First, uncheck the artful ppa using Software and Updates. Then install ppa-purge.

sudo apt-get install ppa-purge

Then remove the ppa, which will downgrade the packages it provided to packages provided by the official repositories.

sudo ppa-purge ppa_name

which in this case is the name of the artful ppa. Just a suggestion.

Edit: For more information on ppa-purge, please see - https://askubuntu.com/questions/307/how-can-ppas-be-removed

You can also remove a ppa by using its’ url:

sudo ppa-purge ppa-url

although I’ve never used this command myself.

@mdooley Did you even read his sources.list? It’s not a PPA , he mixed artful main and universe repos onto a xenial install.

I saw a single line referring to

# New Minetest version
deb http://cz.archive.ubuntu.com/ubuntu artful main universe

I agree that this line is sufficient to thoroughly screw up his 16.04 system.

I missed that this was not a ppa. Thanks for the correction PizzaDude.

I did what @PizzaDude suggested and ended up with one of my problems fixed. The internet now connects automatically at system startup but I am still having video problems. When videos play, you can now hear the audio but you just see a black screen instead of the video (in VLC). Also the home page on Firefox is set to be start.ubuntu-mate.org. I tried setting this back to my original home page but this keeps getting reverted every time I restart Firefox. Also, will Minetest upgrade itself or will I need to add another ppa especially for it?

@rcdronan Here’s a minetest PPA, https://launchpad.net/~minetestdevs/+archive/ubuntu/stable I don’t think you need it right now because it looks like the 17.10 (artful) repos have the latest version of Minetest. As for VLC, you could try reinstalling it or you could use SMPlayer. There’s a PPA for it here.

sudo add-apt-repository ppa:rvm/smplayer
sudo apt update
sudo apt install smplayer smtube

Pair it with MPV as the backend and you have an awesome video player.

There’s an updated version of MPV in this unofficial but good PPA.

sudo add-apt-repository ppa:mc3man/mpv-tests
sudo apt update
sudo apt install mpv

I’m not sure about the Firefox issue.

@rcdronan As for Firefox, change the input in
/usr/lib/firefox/ubuntumate.cfg
That should fix this issue.