System notifications freeze Binding of Isaac


On a 16.04 install on an Asus laptop (Intel graphics), I play Binding of Isaac: Rebirth, but have an annoying problem where the game will freeze 80% of the time there has been a system notification and it goes away. Like, it’s when the notification disappears that it freezes. So I have to Alt+Tab out and force close the game.

I would rather not turn off the notifications as I need to know when the laptop is running out of power.
Please help.

Hi Langley

Lets have a closer look at your hardware. Open a terminal

Ctrl + Alt + t

and enter:

inxi -b

Please post the output.

I forgot to mention that the same happens with the notification for turning volume or brightness up and down. If I turn the volume up for example, the game freezes almost every time the level notification disappears.

System: Host: satellite Kernel: 4.4.0-36-generic x86_64 (64 bit) Desktop: MATE 1.12.1 Distro: Ubuntu 16.04 xenial Machine: System: ASUSTeK (portable) product: X551CAP v: 1.0 Mobo: ASUSTeK model: X551CAP v: 1.0 Bios: American Megatrends v: X551CAP.210 date: 06/04/2014 CPU: Dual core Intel Celeron 1007U (-MCP-) speed/max: 800/1500 MHz Graphics: Card: Intel 3rd Gen Core processor Graphics Controller Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa) Resolution: [email protected] GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 11.2.0 Network: Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169 Drives: HDD Total Size: 40.0GB (80.9% used) Info: Processes: 181 Uptime: 6 min Memory: 959.0/3710.0MB Client: Shell (bash) inxi: 2.2.35 aces

To see the errors you can run steam from terminal with the command steam and see what errors you get there, or even better run steam |& tee -a steam.txt and this will create a steam.txt file with the output of the steam command. When the game crush again put the output at and provide us with the link.

Open up your system monitor (while playing your game) and see how much cpu and if any swap is being used.

Here is the output from terminal. I can’t really find anything relevant.
I might add that Steam popups, such as getting items and achievements, also freeze the game when they disappear.
So it appears that any kind of overlay freezes they game, when they go away.
Looking at the system monitor, around 40% of CPU is being used (probably varies by room), 50% RAM and 0 swap. The game does slow down if a lot is going on though, but that’s actually an advantage.

Have you installed the version of Ubuntu’s repositories or have you downloaded it from the site? Verify that by running apt-cache policy steam (if you see a version here, then it’s from Ubuntu’s repositories) and by apt-cache policy steam-launcher (if you see a version here then it’s from the site).

I installed it from the boutique, but it says steam-launcher is installed.

Software boutique used to install steam-launcher (from the steam repo). If you have enabled the updates at the Ubuntu MATE Welcome then it installs steam (from the Ubuntu repos). Unfortunately, I can’t understand the errors so I can give only some ideas (don’t know if anything will work).

  1. Reinstall steam
    First copy somewhere the folder ~/.local/share/Steam/steamapps (so that you don’t have to download all your games again

    Then remove steam by running the command sudo apt purge steam-launcher and delete the folders ~/.steam and ~/.local/share/Steam.

    Install steam again from the software boutique (if you want enable the updates first so that it will install the Ubuntu’s repo version, but I don’t think it will make any difference).

    Run steam, let it do the update, login with your account and then close steam and delete the folder /.local/share/Steam/steamapps and paste there the previous one which you had saved.

    Finally open steam, go to Library-> YOUR_GAME-> right click-> properties-> Local Files and choose "Verify integrity of game cache` (to make sure all game files are ok).

  2. DIsable overlay and streaming
    Sometimes steam features can cause problems. So, if the above didn’t work then Go to steam Settings-> In-Game and uncheck the option Enable the Steam Overlay while in-game.

    Then go to Settings-> In-Home-Streaming and uncheck the option Enable streaming.

    Also go to Library-> YOUR_GAME-> right click-> properties-> General and make sure that Enable the Steam Overlay while in-game and Use Desktop Game Theatre while SteamVR is active are unchecked.

  3. Delete
    Delete the files:
    These 2 files are just links to old libraries which cause problems sometimes. By deleting them, steam will use your system’s libstdc++ libraries which are newer.

  4. Install kernel 4.7 and/or add oibaf ppa
    If nothing work, then try to install latest stable kernel (kernel 4.7.6 at the moment) and add the ppa: (both may break your system so better to know how to revert the changes)

  5. Try with Ubuntu MATE 16.10
    Ubuntu MATE 16.10 will be released at october 13th. So, give a try then and see if the problems have gone away (make sure that you have purged the oibaf ppa first if you do an upgrade and not clean install).

Thanks for your suggestions, but sadly none of them (except 5.) have helped… so do I report a bug somewhere now or something?

I can add that I do not have this problem on my desktop computer.

I think the right procedure to report this bug is this:

  1. Create a launchpad account (if you don’t have one):

  2. Make sure that the steam version from ubuntu’s repositories is installed.

  3. Run in terminal ubuntu-bug steam. This will gather your system’s info and it will open the steam’s page on launchpad at your browser. Describe there the bug the best you can (make sure you add the link with the steam output).

I do have Steam installed from Ubuntu now, but running that command gives the error `The problem cannot be reported:

The report belongs to a package that is not installed`

Sorry my bad, try the command ubuntu-bug steam:i386