System taking forever to boot after messing with partitions

Update I thought I had fixed the problem when I found out there was a line in the fstab file pointing to the swap partition on the old hard drive so it was trying to mount that partition and put a # in front of it to prevent it from exacting.

But now after I created a NTFS Partition in all but 8 GB of the unused space and then used the remaining 8GBs for the Swap Partition, my system no longer is faster than booting from the hard drive so my SSD did NOT increase the boot time and actually increased it by 7 seconds, booting off the 7200 RPM 1TB Drive takes 42 seconds to fully boot to the Desktop while on the SSD it takes 49 seconds. Before I added the extra partition from the unused space on the SSD and created a Swap Partition my system fully booted in less than 30 seconds.

Windows 10 boots faster but Not Linux.

Below is my original problem that I solved but my system still does not boot any faster than when I booted from a Hard Drive.

After I messed around with my partitions and changed the size of my System Partition by shrinking the Data NTFS Partition that comes after it my system takes a real long time ever to boot, All I did was expand the System partition and shrink the 1 NTFS partition in order to expand the System partition into it. I also have a SWAP Partition after the NTFS Partition and had some unused space after the SWAP Partition. What I had did was get a 1 TB SSD Drive and cloned my 1Tb Hard drive to it, the SSD was slightly larger so when I saw the unused space at the end I tried to use that by deleting the SWAP Partition to expand the data partition into what space it took up and then using the remaining space that the SSD had for the SWAP partition so the number and order of the partitions are still the same, I did not mess with any partitions before the system partition. I've resized partitions before with no problems, it seemed to happen after I tried to use the extra unused space on the SSD.
How do I fix this problem?


I can't even go back and reclone the drive because EaseUS Disk Copy gives me an error message Drive Type Not Supported and won't let me clone the drive even though it did when the SSD was brand new and unformatted, Why would it just overwrite the target SSD drive?

start with systemd-analyze blame to see what service takes too long ...

Is it possible the uuid's in /etc/fstab got messed up?

If that is the case how do I fix it? I don't understand how to edit the fstab file and don't want to mess things up changing something in the wrong way.
The Progam Disks says the SWAP is on /dev/sda8
UUID 25605c05-f0ba-401a-9433-d353f923c5f0
and I see in the FSTAB file

swap was on /dev/sda6 during installation

I assume when there is a Pound Sign in the line it's the same as REM in Basic and the computer won't execute that line.
System Monitor shows the SWAP sa active

lsblk -f will show you all the partitions and their respective uuid. Here's output:

NAME   FSTYPE LABEL UUID                                 MOUNTPOINT
├─sda5 swap         04846c1a-0c14-4e24-a6ad-3a1bb23adb5c [SWAP]
└─sda1 ext4         83628fd7-4884-475b-bf6e-42d94cb6168b /

blkid provides similar output.

/dev/sda1: UUID="83628fd7-4884-475b-bf6e-42d94cb6168b" TYPE="ext4" PARTUUID="0b858aba-01"
/dev/sda5: UUID="04846c1a-0c14-4e24-a6ad-3a1bb23adb5c" TYPE="swap" PARTUUID="0b858aba-05"

Here's the /etc/fstab ...

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=83628fd7-4884-475b-bf6e-42d94cb6168b /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=04846c1a-0c14-4e24-a6ad-3a1bb23adb5c none            swap    sw              0       0

you can edit the file with sudo pluma /etc/fstab


How can I find out what is causing the long boot up time? How do I find out which drive is causing it to take so long to boot? System Monitor shows that the Swap is active and when I right click on the Swap partition in GParted is has the Swap Off option so that means the Swap is active and if I actually click the Swap Off it will disable the Swap partition.

Can you post the top 10 lines ...

systemd-analyze blame
3.067s NetworkManager-wait-online.service
1.337s dev-sda5.device
1.313s udisks2.service
1.181s keyboard-setup.service
944ms snapd.service
898ms ufw.service
605ms mnt-8482BEE982BEDF3C.mount
531ms networkd-dispatcher.service
519ms upower.service
516ms [email protected]

I think that your top entry is partly to blame - NetworkManager-wait-online.service

See -

sudo systemctl disable NetworkManager-wait-online.service cut what felt like 15 seconds off one of my computer's boot time.

Another terminal command to try (and post if it looks suspicious) is systemd-analyze critical-chain

It'll produce something like this -

Update, Nope I did not completely solve it, now after recreating a new Swap partition and creating a NTFS partition in the unused space of the SSD it no longer boots up almost instantly and actually takes slightly longer to boot than with a 7200 RPM 1 TB Hard Drive. It no longer takes forever to boot up but it also is not any faster than booting from a regular Hard Drive.

I solved it, there was a line in the fstab file pointing to the swap partition on the old hard drive so it was trying to mount that partition. I put a # in front of it to prevent it from exacting, I guess I should just delete that line.

Now how do I mark this entire post as solved?