System tray icons not showing in panel 18.04

panel

#1

Hi,

various programs which when I minimize do not show up in the system tray panel. Also the network applet had disappeared since I upgraded from 17.10 to 18.04. I managed to make it show again by:
editing /etc/xdg/autostart/nm-applet.desktop and changed

Exec=nm-applet

to

Exec=dbus-launch nm-applet

Any idea how I can get system tray icons to show again when I click on minimize?

My nm-applet.desktop file looks like this:
[Desktop Entry]
Name=Network
Comment=Manage your network connections
Icon=nm-device-wireless
Exec=dbus-launch nm-applet
Terminal=false
Type=Application
NoDisplay=true
NotShowIn=KDE;GNOME;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=NetworkManager
X-GNOME-Bugzilla-Component=nm-applet
X-GNOME-UsesNotifications=true
X-Ubuntu-Gettext-Domain=nm-applet


Missing panel icons
#2

You need to add to panel ā€œindicator applet completeā€ as notification area does not contain in 18.04 any more those icons. You can look on Mate 18.04 change log for this specific change.

https://ubuntu-mate.org/blog/ go down to ā€œIndicatorsā€


#3

Hi @Dashy, At the same blog @mircea suggests see Known Issues:

Anyone upgrading from Ubuntu MATE 16.04 or 17.10 may need to use MATE Tweak to reset the panel layout to one of the bundled layouts post upgrade. Migrating panel layouts, particularly those without Indicator support, is hit and miss. Mostly miss.

This may be the easiest, depending.


#4

I have similar issue - after upgrade from 17.10 there are no more icons of Qt-based apps in ā€˜Notification areaā€™ applet, such as VLC, Telegram (Qt5) or Goldendict (Qt4) and others. Reset panel didnā€™t help. Maybe anyone knows is there a way to get back these icons?


#5

The suggestion by mircea to

You need to add to panel ā€œindicator applet completeā€ as notification area

did work and shows system tray icons. However am missing the network connection icon.

Any idea how to make it show? It is shown in the screenshot of the blog article: https://ubuntu-mate.org/blog/


#6

For anyone following up on this, a bug has been reported here:
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1754458


#7

Hello,
Thanks to @Dashy URL, you may now try a trick posted on Aug 20, 2018 at https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1754458 in comment #15 :

  1. Edit this file : /usr/share/indicator-application/upstart/xdg/autostart/indicator-application.desktop

  2. Add MATE in the following option such as :

OnlyShowIn=Unity;MATE
  1. Reboot.

Missing icons should be restored.

  • In ā€œStartup Applicationsā€ (or ā€œControl Centerā€ > ā€œStartup Applicationsā€), ensure thereā€™s no Ayatana application enabled to start on boot.
  • Make sure to undo other modifications you attempted for fixing this problem before now.

Thereā€™s another trick on post #21 on the same link.


#8

This is simply not true. I tore that indicator crap out of my panel because it in my opinion is ugly, unconfigurable and ignores system theme. I replaced it with traditional Notification Area applet, and it works great just as it always did.