System won't boot up - initramfs

Hoping someone can help otherwise I've lost a weeks worth of work.

Started the laptop this morning and got the error: couldn't get size

then Busybox v1.27.2 (Ubuntu 1:1.27.2-2ubuntu3.2) built-in-shell (ash)

Then a prompt after (initramfs)


First I would try to boot recovery mode from grub menu.
And if it fails, I would boot from an USB stick or a live CD to check filesystems of internal disk.
If no problems found regarding to filesystem, I would reinstall grub.
Here is a good method:


Thanks for the reply. I've managed to get the laptop going via a live image on USB and recover my files from the hard drive.

As this is new to me, what is the next step.?

How do I know if the problem is with the grub? If there was a problem with the grub.


The link @sipizolix post would be one of the easier ways to safely fix grub and give you a bootable system.

Brilliant, thanks very much. I will try the link.

Tried the link and unfortunately nothing worked for me.
I ended up doing a fresh install of Mate.

Not the end of the world really, just time consuming.