Terminal opens and closes

All right guys, I have a problem, I added a command in the terminal profile, but the terminal opens and closes and I can't use it, could you help me please, thanks.

Hello, Souza!

First of all, welcome to the community!

If you added a command on your ~./profile, a normal scenario would be that any commands written on it will be executed when the user log in, and then terminated. Thus, it seems that this behavior is expected.

If this is not your case, please provide more details so we can help you better!

1 Like

Another interpretation of your issue is that, after adding commands to your ~./profile, every time you try to open your terminal, it closes unexpectedly.

If this is your case, please provide us which commands you added.

Also, if you remove those commands and the issue goes away, it is a probable sign that your commands may be written or programmed incorrectly.

1 Like

occasionally I added a command when starting the terminal by configuring the profile in the menu bar of the terminal itself I went to the profile preferences, added the screnfetch command, however it opens and even runs but closes then, I tried to remove the screenfetch but it didn't work I reinstalled the terminal nothing too, I removed it with purge it didn't work ...

Have you tried copying the original files from /home/ubuntu-mate in a live session to your device in /home/$USER? That is a sure-fire way to reset back to default without needing to trace back your steps.

Don't forget to back up your now defective changes to learn from them and iterate in future. Also, keep the original next time around, and if you'd like for convenience purpose ln to make a symbolic link so if you mess up to where you can't trace it down, you can remake the link to the original to at least have a functional profile.


Just a thought. The package dconf-editor allows accessing the terminal profile settings. The path I find for the default profile is below. Hopefully, you should be able to alter the command you entered.


Thank you very much, it worked! :grin:

Not exactly sure what you are trying to do.... But... If you want a command(s) to run automatically when you open a terminal, just add them to the end of /home/{user}/.bashrc

This is where I load my aliases that I like to use and have neofetch run on terminal open.

For example, this is the end of my .bashrc file. I issue the command to run a script to load my aliases. "cls" is an alias that clears the screen and runs neofetch.

Load Aliases

. ~/MEGA/OS/Linux/Aliases/aliases

Clear Screen