Terrible mouse lag after updating to 22.04

I've just updated from 21.10 to 22.04 where I had a completely normal working mouse to now its really laggy and slow. I've tried adjusting the usbhid.mousepoll settings in cmdline.txt and its made it slightly better but nowhere near what it was like.

Whats changed between releases to make this happen?

Was this a clean install of the OS? I ask because the last time I played with the R-Pi was when the 22.04 image was released and I had no problems as you describe. In fact I was really impressed with how smooth the experience was.

If you did an in place upgrade rather than a fresh install, that may account for the difference. If you did a fresh install then either there's been a regression or it's a hardware problem. One thing I would do is replace the battery in the mouse if you're using a wireless mouse.

Hope it works out for you.

1 Like

It was an in place upgrade :expressionless:

I've tried a few different mouses (mice?!) and they're all the same.

Going to try a fresh install using another drive to determine whether or not its a hardware problem.

As expected, the in place upgrade looks to have broken something.

I installed Mate 22.04 to a spare micro sd card and booted up, I had to add usbhid.mousepoll=0 to the cmdline.txt file, however after doing that it was fine.

SOLVED!. I've managed to fix it, here's what I did.

Spotted on another forum that someone had similar issues with Manjaro and they'd changed the following in /boot/firmware/config.txt

dtoverlay=vc4-fkms-v3d
to
dtoverlay=vc4-kms-v3d

So I thought I'd give it a go and its worked. I'm not 100% sure what the implications of this are but for now I've got a usable desktop again.

2 Likes

Does this option work now on Raspberry Pi3 (as I know will boot with dark screen)?

Solved... I deactivate the option ... so no more 3D acceleration ... now mouse behave normally.
The KMS does not work on 22.04 Pi3 armhf, just Legacy and FKMS... prefer legacy because of mouse issues.