Tethering a phone for data anomaly

My home does not have any a landline phone or broadband connection. I use an Android phone with unlimited Data for either wireless or USB tethering.
When using any of my Linux computers and doing updates I frequently get errors about download failures right at the end. There is always just a few kilobytes short and if I run say apt upgrade again I get need to download a few kilobytes and it will complete.
Anyone else had this happen?


I do. You didn't mention your provider, but I, and neighbors for miles, have only one tower in range, and no other broadband available. From 5 to 8 in the evening, access is so heavy nearly every request times out before returning full data.

I also think, that at least in my case, the tower owner has to daisy chain data from there to another tower, because this one is on top of a mountain, and nothing but electric runs on any poles anywhere nearby.

I don't know how providers prioritize, but I suspect voice traffic goes first, then data, then after that the customers whose provider only lease tower access, as opposed to the tower owner's own customers.

Can you schedule your updates, either automatically, or with a cron job for middle of the night? At least in my case, I get fast access at off peak times.

Another thought is to see if you have truly unlimited data. Some providers officially (or unofficially) throttle after a certain amount of data per month. It may be unlimited, but much slower. You'd never hit the limit unless you are streaming video or downloading, say, a kernel update.


I can use the internet any time of day or night and watch youtube etc without any issues. This only happens when i am installing software or updating on Linux.

can you share the repos you're using? ... inxi -r

Just to clarify a couple of things. I have three laptops and three desktop PCs. All of them have Ubuntu flavours on them. It makes no difference what version or flavour of Ubuntu or other Linux distro I am using. The issue only arises when I am tethering and installing software or updating from the default or any other repo and only while doing that will it happen. Its always just several Kbytes and if I run apt upgrade it completes the last few Kb within seconds and installs.

it seems the issue is with your phone provider (T-mobile, Verizon, ATT, ...). if you have llong ping times with the default ubuntu repos, the issue is with the phone network. My opinion.

1 Like