Thunderbird - Configuration Could Not Be Verified

I really hate Google right now, but that’s beside the point. I have been using Thunderbird for years. And it’s my understanding that Google has changed their security protocols so that you can’t use a 3rd party email client unless you check some setting to allow “less secure” apps. I did that. I actually managed to set up my email accounts, after multiple attempts and much frustration, on Evolution. I prefer to use Thunderbird, however, and I can’t get my emails set up on it. Correction, I initially was able to get my emails set up. I recently had to do a reinstall of the OS. When I first set up my email, everything seemed to be working fine, and it was working without my needing to check the less secure apps box. I’m not sure what happened but all of a sudden everything just stopped logging in. I tried turning off the firewall. I tried deleting the accounts. I then tried deleting and reinstalling Thunderbird. Nothing seems to work. Now I’m concerned that in uninstalling it I may be missing something to help it to work, even though it wasn’t working at the time that I uninstalled it. At the moment, this issue seems to be specific to Thunderbird. Is there any way to fix this?

Also since I’m here, if anyone has any recommendations for free or paid email services that work well with Thunderbird, I more than welcome the recommendations. Google is making it way too difficult to just access my email someplace other than a browser or their Android app. It may be time to start migrating my email. TIA.

Not normally one to recommend anything Microsoft, but hotmail currently works with Thunderbird.


I just set up a gmail account in Thunderbird and everything seems to be working fine. Did you setup using IMAP or POP3? I didn't have to check anything to allow "less secure" apps using IMAP.

However I can see what you are talking about...

Interesting. I’m using IMAP. The weird thing is that I initially had no problems. Everything just stopped working all of a sudden. I got the information about checking the less secure apps box from doing some searching, and so far that’s the only thing that seems to have worked, at least on Evolution. It hasn’t made any difference at all in Thunderbird.

edit: I just unchecked the box in settings, in my browser, and now Evolution is back to not being able to log in. So, there’s definitely an issue there. It’s just that for some odd reason Thunderbird isn’t able to log in no matter what. I’ve been using Thunderbird with gmail for years without any issues, and as of a few days ago, it was still working. I have no idea what went wrong.

Interesting - I’ve not received such a message.

Thunderbird 52.5.0
Gmail via imap
Ubuntu 16.04.3 | MATE 1.16.2
FireFox 57.0.4

According to this page

To help keep Google Accounts through work, school, or other groups more secure, we block some less secure apps from using them. If you have this kind of account, you’ll see a "Password incorrect" error when trying to sign in.

Are you accessing through work, school, or another group?

I found the less secure apps option pictured below. Mine is turned off and Thunderbird still works correctly.

When I setup Thunderbird to use gmail, I was pesented with a option that allowed Thunderbird to have access to my gmail account.

Now at this location

I see this

If you don't see the same in your gmail account settings, you might try removing your gmail account from Thunderbird, then add it again to see if you get a option to add Thunderbird as trusted third party app.

I originally did get the message to use Thunderbird as a third party app. That’s what I was saying above. Everything was fine, but it just stopped working all of a sudden. I’m accessing my mail from home. So, that shouldn’t be a problem. I removed my accounts from Thunderbird and even went so far as to uninstall and reinstall it, but nothing seems to have worked to get it to go back to normal.

Sounds like something is blocking your login attempts. I was thinking firewall, but you said you tired turning it off.

So maybe it has something to do with your Account Settings in Thunderbird.

Please check your settings against the following screenshots...

Some other things to consider.

When you reinstalled Thunderbird, how did you do that? Software Boutique? Synaptic? apt? Website download?

What version of Thunderbird do you have?

I'm using 52.5.0 (64-bit) on Ubuntu Mate 16.04.3 LTS 64-bit

Could it be possible that there are corrupt files in your home folder?

Have you tried deleting




then setting up your account in Thunderbird again?

You might even try creating a new user account on you system and setting up Thunderbird in it.

There has to be some setting or configuration on your system that has changed and is preventing you from logging in. Like you said in your first post...

Something has changed, and I don't feel like its on the gmail servers since it's working on my machine.

1 Like

So, I’m also using 52.5.0 (64-bit) on Ubuntu Mate 16.04.3 LTS 64-bit. I reinstalled it via the Ubuntu Software Center. It was surprisingly not listed in the Software Boutique. I guess because it came pre-installed? At any rate, all the settings were as they appear in your post.

I just uninstalled it again, and I’ve removed the thunderbird folder per your recommendation. I’m going to try reinstalling it again from the Software Center. This time I’ve disabled my firewall and also my VPN. I’ll report back on how that goes. I’ve also unchecked the “allow less secure apps” box in my email settings, because that wasn’t checked the first time when Thunderbird was working.

Okay, I was able to successfully reinstall and get my email accounts up and running. There seem to be two potential problems both of which I just listed in my previous post. The first is my VPN. I’m not sure why that should be a problem, since I’ve been using Thunderbird with my VPN running for a long while now (close to 2 years). The second appears to be the firewall. Even though I disabled the firewall previously, whatever enabling it in the first place triggered wasn’t helped by subsequently disabling it. I think the firewall is the larger issue here, because now that I’m thinking about it a bit more, I seem to remember things going cablooey the first time after I enabled it. I’m going to try rebooting my machine and turning on the VPN to see if the reboot will help Thunderbird (or Gmail). Thanks for the help. I think that deleting the Thunderbird folder helped to reset everything so that I could properly set up my accounts again.

That seems to have worked. Gmail is now able to connect through Thunderbird while the VPN is running, which brings me back to the idea that the issue was likely the firewall. I had disabled the firewall, but whatever enabling it did couldn’t be undone by disabling it. Now I have to figure out how to get my firewall running without interfering with Thunderbird and Gmail.

OK, Thunderbird is working again. Great!

The default setting for the firewall that ships with Ubuntu Mate (gufw) is to allow outgoing and deny incoming traffic. So it shouldn’t block gmail by default.

However, you could create a rule in your firewall that allows a outbound connection to the gmail servers.

There is a decent how to here…

1 Like

An aside to the Thunderbird issue. I love thunderbird, and I use an addin called “Sunshine” which gives me a calendar and task application within Thunderbird. It is just like having Outlook, without the MSFT (pronounced, “misfit”).

1 Like

I just got the same issue and this worked for me:
Thunderbird menu >> Help > About Mozilla Thunderbird >> Restart to update